The No.1 Website for Pro Audio
Spring Reverb Issue
Old 31st October 2021
  #1
Lives for gear
 
andrew montreal's Avatar
 
🎧 10 years
Spring Reverb Issue

Hi all,

I am testing out an Orban Spring Reverb... the classic 119b.

I have come across an issue. On one of the channels, it seems the input signal is not making its way to the spring. If I tap the unit, I can hear the spring bouncing around on both the direct out (which is actually the wet out) and the mix output. I can also hear the input signal on the mix output. BUT, no input signal is making it to the spring. Thoughts?

Andrew
Old 1st November 2021
  #2
Lives for gear
 
Paul_G's Avatar
 
🎧 10 years
Quote:
Originally Posted by andrew montreal ➡️
Hi all,

I am testing out an Orban Spring Reverb... the classic 119b.

I have come across an issue. On one of the channels, it seems the input signal is not making its way to the spring. If I tap the unit, I can hear the spring bouncing around on both the direct out (which is actually the wet out) and the mix output. I can also hear the input signal on the mix output. BUT, no input signal is making it to the spring. Thoughts?

Andrew
It’s broken? Ask the Geeks.
Old 1st November 2021
  #3
Lives for gear
 
Rick Dalton's Avatar
Quote:
Originally Posted by andrew montreal ➡️
Hi all,

I am testing out an Orban Spring Reverb... the classic 119b.

I have come across an issue. On one of the channels, it seems the input signal is not making its way to the spring. If I tap the unit, I can hear the spring bouncing around on both the direct out (which is actually the wet out) and the mix output. I can also hear the input signal on the mix output. BUT, no input signal is making it to the spring. Thoughts?

Andrew
Seen a ton of 111b, no 119b. I'd have a look inside if were you, look for loose leads, Might as well clean the pots while youre in there.
Old 1st November 2021 | Show parent
  #4
Lives for gear
 
andrew montreal's Avatar
 
🎧 10 years
Quote:
Originally Posted by Paul_G ➡️
It’s broken? Ask the Geeks.
Ask the Geeks? Funny, I thought I was.

Is The Geeks a Forum out here? (I shall go investigate.
Old 1st November 2021 | Show parent
  #5
Lives for gear
 
andrew montreal's Avatar
 
🎧 10 years
Quote:
Originally Posted by Rick Dalton ➡️
Seen a ton of 111b, no 119b. I'd have a look inside if were you, look for loose leads, Might as well clean the pots while youre in there.
Wow! This whole time I have been reading 119b. It is indeed a 111b

Thank you for the suggestion. I did indeed do that. Without taking out the board to look underneath, I followed all the leads and everyone seems to be holding on to both end of his deal.
📝 Reply
Post Reply

Welcome to the Gearspace Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…

Forum Jump
Forum Jump