Quantcast
RODE NT1 doesn't get Phantom Power - Gearspace.com
The No.1 Website for Pro Audio
RODE NT1 doesn't get Phantom Power
Old 28th December 2018
  #1
Here for the gear
 
RODE NT1 doesn't get Phantom Power

I had been using a Presonus starter studio kit that came with an Audiobox USB interface, XLR balanced cable, an M7 Presonus microphone and a pair of headphones. I've since been able to get my investment back and make a good amount of cash, so I decided to upgrade to the NT1KIT. It arrived a couple weeks ago, and everything seemed to be just fine. Took off the M7, connected the NT1 to the XLR and then to the interface, and voila, all was well.

Suddenly, last morning this microphone was simply not working anymore. It doesn't get phantom power when I turn it on, it only works when I connect it to the second XLR plug on the interface and turn the gain all the way up, and even then it's really quiet and there's a loud hissing in the background. I tried connecting the M7 and there was absolutely no issues.

I decided to go to the local music shop to get some advice. Plugged it into a mixer there, gave it phantom power, it worked for like 10 seconds before the sound started slowly dying out. I went around town doing some more errands and when I came back and plugged it back in, magically, it worked. And it worked all day; until night time, where it decided not to again. The sound either comes and goes, or doesn't appear at all, or is there as if there was no problem. I don't know what the issue could be. I'm tempted to ask for a refund but I bought it on amazon and I bet it's gonna be a huge hassle. I want to believe there's an incompatibility issue between the interface or the cable and the mic; but I really don't think so after going to the music shop. Please help.
Old 28th December 2018
  #2
Have you been using the same mic cable for all these scenarios, including trying it at the store? if yes, its prob your cable. If not, the mic is bad and needs to be returned.
Old 28th December 2018
  #3
Lives for gear
 
MarkF48's Avatar
 
🎧 5 years
If the mic (the capsule specifically) may have been exposed to a damp/humid environment if may not work and/or it may output noise such as hiss or a wind like sound. If you think this may be the case, place the mic in a plastic ziplock bag with some desiccant packs overnight or some place warm and dry, but not excessively hot (don't use a hair dryer!!)
📝 Reply

Similar Threads

Thread / Thread Starter Replies / Views Last Post
replies: 54 views: 184836
Avatar for Jorell Davis
Jorell Davis 10th January 2020
replies: 425 views: 37784
Avatar for Denta
Denta 9th January 2021
Post Reply

Welcome to the Gearspace Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…

Forum Jump
Forum Jump