Quantcast
Boss GL-100 question - Gearspace.com
The No.1 Website for Pro Audio
Boss GL-100 question
Old 11th September 2012
  #1
Lives for gear
 
Mikhael's Avatar
 
🎧 5 years
Boss GL-100 question

I got one of these to use for quick & dirty DI on guitars. It sounds pretty darn good, EXCEPT for one thing: there's a little crackly, nasty distortion that appears on either channel, at any setting. It does take a little bit of signal to make it happen, but not an excessive amount. It happens independant of the distortion created by the unit. I was wondering if anyone had experienced this before, and might have an idea of what it was?

With the parametric mids, and the choice of distortion voicings, I'm able to get a real nice edge-of-disortion rock sound out of the thing, and the clean sound is surprisingly nice - except for the crackly bit of sound the rides on the tone. The regular distortion has the highs muted by the speaker emulator, but this little crackly thing seems to be something else. I've cleaned the pots and experimented with gains, but it still shows up.

Any ideas? Please? I know this is a longshot, but I'm really trying to get this thing functional.
📝 Reply
Topic:
Post Reply

Welcome to the Gearspace Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…

Forum Jump
Forum Jump