Quantcast
Peavey Delta Blues Tube, sound only w/ ext. Cab - Gearspace.com
The No.1 Website for Pro Audio
Peavey Delta Blues Tube, sound only w/ ext. Cab
Old 19th January 2019
  #1
Here for the gear
 
Peavey Delta Blues Tube, sound only w/ ext. Cab

Peavey Delta Blues Tube amp 1x15 makes no sound but works with ext. Cab 4x12 , Also the internal speaker works when the ext. cab is plugged in

Help????
Old 19th January 2019
  #2
Lives for gear
 
enorbet2's Avatar
 
🎧 10 years
I've never had a Dealta Blues on my bench so all I have to go by is the schematic, but it appears to me that there is a multipin connector interface that connects the output transformers secondary to the Internald and External speaker jacks and those jacks have switches engaged when plugged in. All of those need to be checked - The OT for any open windings, internal or simply a bad connection; the quality of both soldered and mechanical connections at the multi pin interface connector; and whether or not the switches built into the speaker jacks are working properly or not..

It should be an easy fix for anyone with a multimeter and a bit of circuit knowledge..
📝 Reply
Post Reply

Welcome to the Gearspace Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…

Forum Jump
Forum Jump