View Single Post
Old 10th January 2012
Gear Head
"Unable to locate Digidesign hardware" message fix!!

Hey everyone!

I'm a longtime lurker at Gearslutz, but after discovering a fix to a seemingly common problem without an apparent solution I figured I would share it.

Since last November up until recently I was having some pretty major problems with PT. Everytime I would open up it up I got a message that said "Unable to locate Digidesign hardware. Please make sure it is plugged in or turned on then click ok". Long story short, I did everything I could find on Google short of completely reinstalling Pro Tools. I reinstalled the drivers, tried to manually point Pro Tools in the right direction via the Device manager, deleted my prefs...Heck, I probably even hit it a few times, but literally NOTHING was working. Frustrated I finally contacted Avid via email with one of their support code thingys. I sent my Mbox Mini in to get repaired, then when I got it back I opened the box, plugged it in, and got the same exact warning again. Feeling very exasperated at this point, I emailed Avid again to let them know, and they told me to call their technical support. I called them and talked to Connor, who linked our computers for about a half hour and fixed the whole problem! Here's what he did:

1.) User Account Control Settings: Go to "Control Panel" on the Start menu then click "User Accounts". At the bottom of the list in the center of the screen, you should see "Change User Account Control Settings". Click that then drag the slider down to "Never notify". Click "Ok" and close the window.

2.) Uninstall all Avid Mbox Drivers: Go to Control Panel again and click on "Programs and Features". You should see a list pop up that's populated with all of the programs on your computer. Locate the program that is labeled "Avid Audio Drivers". (Some of you may or may not have that installed on your computer. I think it depends on the version of PT you have or something like that). Also locate the driver icon for whichever model of Mbox you have. It will say something like "Avid Mbox *model* Driver (Without the asterisks obsiously). Uninstall both by hitting "Uninstall" at the top of program list. Windows will guide you through the rest. You may be prompted to restart at this point. I seem to have forgotten to take notes about that part...It's not a bad idea to restart though even if it doesn't prompt you too.

3.) Reinstall all Avid Mbox Drivers: Open your web browser and go to Click on "View Available Downloads" at the top of the page and download the one for windows. If you don't see an installer then go to your browser's download list and click the zipped folder icon. There should be an installer that will guide you through the rest. Make sure to restart after this too.

4.) Run as Administrator: This is probably the most important step out of all of them. After your computer restarts, right click on the Pro Tools shortcut on your desktop. If you don't have a short cut on your desktop, you should be able to drag a shortcut from the start menu or the Start bar to the desktop. After right clicking, click on the "properties" at the very bottom of the drop down menu. Click the "Shortcut" tab on the top of the window. Click "Advanced" at the bottom right, about 2/3rds of the way down. Click the check box that says "Run as administrator". Click "OK" to close the windows. Double click on the PT shortcut and PT will hopefully open right up!

This might not work for everyone, but it worked for me. I hope this helps a little! FYI, if you call technical support you might have to wait awhile. I waited 40 minutes on hold until I talked to someone.