Saffire Mix Control not booting - Gearspace.com
The No.1 Website for Pro Audio
Saffire Mix Control not booting
Old 28th January 2013
Here for the gear
🎧 5 years
Saffire Mix Control not booting


I recently purchased a new iMac running OS10.8.2 and ever since I haven't been able to get Saffire Mix Control for my Liquid Saffire56 to run. Every time I launch it, the program unexpectedly quits.

Has anyone else had this issue and does anyone have a solution for it? I tried uninstalling and reinstalling the software.
I've tried browsing through focusrite's troubleshooting tips and couldn't find anything.

📝 Reply
Post Reply

Welcome to the Gearspace Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.

Slide to join now Processing…

Forum Jump
Forum Jump