Quantcast
FL Studio CPU at 99% but Task Manager is at 30% - Gearspace.com
The No.1 Website for Pro Audio
FL Studio CPU at 99% but Task Manager is at 30%
Old 26th January 2013
  #1
Gear Head
 
🎧 10 years
FL Studio CPU at 99% but Task Manager is at 30%

I've tried disabling my Firewall, I ran Disk Warrior (I'm in Bootcamp), and I ran CCleaner. FL Studio is still locking up even though I've bounced all but 2-3 synths running at a time, which is typically 2 Sylenths (with minimal polyphony) and one Nexus2--because I'm still tweaking the lead sounds. The only third party effect I'm using is Maserati GTi but even when I disable that, I still have 99% CPU and crazy underruns, sometimes freezing my project completely. I'm on an i7 Macbook Pro with 16GB RAM, saving my projects on an external drive, and using the "extended memory" version of FL. I've switched to "smart disable all plugins", and did automatic delay compensation if that makes any difference. I'm running a Fiio E17 soundcard using their ASIO driver, with the buffer size at max. I am not running anything outside of FL simultaneously, and I cannot for the life of me figure this out.
Old 26th January 2013
  #2
Gear Maniac
 
🎧 10 years
Most likely the ASIO driver from that interface. Try ASIO4all and see if it improves.

CPU meters in DAW´s are not directly related to the the real cpu consumption, but how fast the DAW can stream audio with the chosen driver.
That´s why some interfaces like RME´s get the lowest latency´s on the same system where some other brand are causing clicks and pops..

cheers
submarin
Old 26th January 2013 | Show parent
  #3
Gear Head
 
🎧 10 years
Quote:
Originally Posted by submarin ➡️
Most likely the ASIO driver from that interface. Try ASIO4all and see if it improves.

CPU meters in DAW´s are not directly related to the the real cpu consumption, but how fast the DAW can stream audio with the chosen driver.
That´s why some interfaces like RME´s get the lowest latency´s on the same system where some other brand are causing clicks and pops..

cheers
submarin
Hey man, thanks for replying. Changing to ASIO4all didn't help, but thanks. Can you recommend any good soundcards? I'm thinking of the Focusrite Saffire 2i2.
Old 26th January 2013
  #4
Gear Addict
 
🎧 5 years
Desktop Konnekt 6 - FireWire Audio Interface & Monitor Control | TC Electronic

Trust me, that's the best you're going to get around that price. It's a bargain too.
Old 26th January 2013 | Show parent
  #5
Lives for gear
 
1 Review written
🎧 10 years
Quote:
Originally Posted by alexfsu ➡️
Can you recommend any good soundcards? I'm thinking of the Focusrite Saffire 2i2.
I would recommend anything from RME. The hardware is solid and the driver support is outstanding. I'm still using RME interfaces I bought over 10 years ago and they're still updating drivers for them. Few companies can claim that.
Old 26th January 2013
  #6
Gear Maniac
 
abaga129's Avatar
 
🎧 5 years
Are you experiencing audio dropouts and pops? If so try setting your audio buffer to the max length.
Old 27th January 2013
  #7
Gear Head
 
🎧 10 years
I just discovered that two windows are open when I work on projects. I'm a new user to FL so I thought this was normal, but I don't think it is. Like, when I right click the taskbar FL icon in Win 7, one mini window pops up with my project labeled and the arrangement pictured, and another mini window sits beside it that is light grey and has an FL symbol in the middle of it. However, if I "X" out of the light grey dummy window, it closes my project altogether. Same if I "X" out of the project window. So it's not my soundcard necessarily. Any ideas?
Old 27th January 2013
  #8
Gear Maniac
 
ModernMixing's Avatar
 
🎧 5 years
Hey I had issues with CPU in FL. Its still not perfect but its most like one or two plugins thats being a hog.

try reading this and see if it helps. It helped me a little bit.

Optimizing FL Studio performance

You can also "Freeze" tracks by recording them into Edison and then disengaging the plugins attached to the sound.
Old 27th January 2013 | Show parent
  #9
Gear Head
 
🎧 10 years
Quote:
Originally Posted by ModernMixing ➡️
Hey I had issues with CPU in FL. Its still not perfect but its most like one or two plugins thats being a hog.

try reading this and see if it helps. It helped me a little bit.

Optimizing FL Studio performance

You can also "Freeze" tracks by recording them into Edison and then disengaging the plugins attached to the sound.
I've tried every single one of those suggestions and no dice. Appreciate it tho.
Old 31st January 2013
  #10
Gear Head
 
🎧 10 years
Bought a Focusrite 2i2 soundcard.
Reinstalled FL Studio.
Ran DPC latency checker, at about 500u - 1000u.
Ran Apple Hardware Check, came back fine.

Still same problem.

If I press one key from an init Massive patch, I get about 25% CPU. Nexus goes up to 99% if I press a triad in quarter note lengths. I have tried everything. Please help if you can. Thank you.
Old 31st January 2013
  #11
Lives for gear
 
🎧 5 years
Using original software or...?

What cpu do you have?
Old 31st January 2013 | Show parent
  #12
Gear Head
 
🎧 10 years
Quote:
Originally Posted by FoxMulderFBI ➡️
Using original software or...?

What cpu do you have?
FL 10.0.9c
Win 7 x64 SP1
Macbook Pro i7 16GB RAM through Bootcamp
Old 31st January 2013
  #13
Lives for gear
 
🎧 5 years
i7 means nothing, there are many i7 types of cpu's. Although, none of of the i7's should have problem with Sylenth and Nexus, unless you are using some crazy polyphony (voice count).

Does the same thing happen with other synths and your projects?
Old 31st January 2013
  #14
Lives for gear
 
🎧 5 years
Possible problems: using windows on mac, cracked software, buffer level not set properly, crazy polyphony, missing proper drivers...
Old 31st January 2013
  #15
Lives for gear
 
valis's Avatar
 
1 Review written
🎧 15 years
Or only using a single core....for whatever reason.
Old 31st January 2013 | Show parent
  #16
Gear Head
 
🎧 10 years
Quote:
Originally Posted by FoxMulderFBI ➡️
Possible problems: using windows on mac, cracked software, buffer level not set properly, crazy polyphony, missing proper drivers...
Happens for all synths in each project

Buffer level is at max for Saffire 2i2 (10ms)

Driver is most recent

Polyphony for Massive was 1 and I still get 20% CPU

Using FL demo

Can't find any past issues on the Internet about using FL on Mac

I suspect it could be a core issue, but I don't know anything about that topic. :/
Old 31st January 2013 | Show parent
  #17
Lives for gear
 
Phaidon's Avatar
 
🎧 10 years
Quote:
Originally Posted by alexfsu ➡️
Using FL demo
/
demo or crack?
Old 31st January 2013 | Show parent
  #18
Gear Head
 
🎧 10 years
Quote:
Originally Posted by Phaidon ➡️
demo or crack?
10.0.9 demo
Old 31st January 2013
  #19
Lives for gear
 
Phaidon's Avatar
 
🎧 10 years
do you have any other programs that you can test for comparison?
like Ableton Live or Studio One? they both have demo vrs
tbh I dont think it's an FL thing,most likely a Bootcamp setting of some short.
Old 31st January 2013
  #20
Lives for gear
 
🎧 5 years
Why don't you ask on image line FL forum? I am sure some people over there are experts on FL and they'll have answer for you.
Old 31st January 2013
  #21
Gear Head
 
🎧 10 years
Tried Reaper demo on Win and Ableton full on OSX, both fine. I am using the FL demo, they only let you ask questions if you're a customer. :/
Old 31st January 2013 | Show parent
  #22
Lives for gear
 
DaveE's Avatar
Quote:
Originally Posted by alexfsu ➡️
Buffer level is at max for Saffire 2i2 (10ms)
There it is. 10ms is not MAX- that's your lowest latency setting. Start moving in the opposite direction
Old 31st January 2013
  #23
Lives for gear
 
Phaidon's Avatar
 
🎧 10 years
I believe he had the same prob even before the Saffire came into the equation
Old 31st January 2013 | Show parent
  #24
Gear Head
 
🎧 10 years
Quote:
Originally Posted by DaveE ➡️
There it is. 10ms is not MAX- that's your lowest latency setting. Start moving in the opposite direction
No I'm afraid that makes it worse.
Old 31st January 2013
  #25
Lives for gear
 
DaveE's Avatar
Try setting it at 1024
Old 31st January 2013 | Show parent
  #26
Gear Head
 
🎧 10 years
Quote:
Originally Posted by DaveE ➡️
Try setting it at 1024
I can't, it goes from 1ms to 10ms...see attachment
Attached Thumbnails
FL Studio CPU at 99% but Task Manager is at 30%-driver.png  
Old 31st January 2013 | Show parent
  #27
Lives for gear
 
DaveE's Avatar
Quote:
Originally Posted by alexfsu ➡️
I can't, it goes from 1ms to 10ms...see attachment
I don't own Fruity Loops. What kind of values do you see when you slide to the left?
Old 31st January 2013 | Show parent
  #28
Gear Head
 
🎧 10 years
Quote:
Originally Posted by DaveE ➡️
I don't own Fruity Loops. What kind of values do you see when you slide to the left?
1-10 consecutively

latency at 1ms is input 5, output 6
latency at 5ms is input 13, output 18
Old 22nd December 2013
  #29
Here for the gear
 
🎧 5 years
I got the same issues with my dell laptop just 2 days ago.

I suspect it is a power issue.
*Might be the battery
*Might be the charger

Edit:
In settings>Project>General my timebase (ppq) was set to 960 setting at 96 solved it.
📝 Reply

Similar Threads

Thread / Thread Starter Replies / Views Last Post
replies: 60 views: 13725
Avatar for smokingrobot
smokingrobot 29th May 2012
replies: 2376 views: 404627
Avatar for didier.brest
didier.brest 3 days ago
replies: 70 views: 102643
Avatar for MicheleS76
MicheleS76 30th August 2020
Topic:
Post Reply

Welcome to the Gearspace Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…

Forum Jump
Forum Jump