Quantcast
Logic Pro 9 single CPU core overload--LAME!! - Gearspace.com
The No.1 Website for Pro Audio
Logic Pro 9 single CPU core overload--LAME!!
Old 18th September 2012
  #1
Lives for gear
 
🎧 10 years
Logic Pro 9 single CPU core overload--LAME!!

Just spent 2 nights creating an elaborate Multitimbral/Multi Output in Logic Pro 9. Had it set up with Maschine, Stylus RMX, Kontakt, Omnisphere, Guru, Nerve etc. All the multi audio outputs from plug-ins were routed through Aux channels. Upon loading some loops and patterns to make sure things were routed correctly i noticed that a single cpu core was spiking into red. Project stopped a few times due to overload error message.

I then did some search and found that Logic cannot distribute aux channels on separate cpu cores and that this issue was quite common and known.........

I am so disappointed. This is my main DAW, my livelihood, productivity depends on this. For a program which is known as a superior DAW for composers, this is a very strange issue......more so because the hardware we run it on is designed and manufactured by the same company!!!

Are there any workaround to this ?
How do u professional composers dealing with many Kontakts, Omnispheres etc work around this issue ?
SHould i just go back to running different instances of the plug-ins other than multi timbral ones ?

Do others DAWS suffer the same; is this a Multi Core design thing ???

I'm really bummed out........

Thanks
Old 19th September 2012
  #2
Lives for gear
 
EastWest Lurker's Avatar
 
🎧 10 years
Quote:
Originally Posted by nyne ➑️
Just spent 2 nights creating an elaborate Multitimbral/Multi Output in Logic Pro 9. Had it set up with Maschine, Stylus RMX, Kontakt, Omnisphere, Guru, Nerve etc. All the multi audio outputs from plug-ins were routed through Aux channels. Upon loading some loops and patterns to make sure things were routed correctly i noticed that a single cpu core was spiking into red. Project stopped a few times due to overload error message.

I then did some search and found that Logic cannot distribute aux channels on separate cpu cores and that this issue was quite common and known.........

I am so disappointed. This is my main DAW, my livelihood, productivity depends on this. For a program which is known as a superior DAW for composers, this is a very strange issue......more so because the hardware we run it on is designed and manufactured by the same company!!!

Are there any workaround to this ?
How do u professional composers dealing with many Kontakts, Omnispheres etc work around this issue ?
SHould i just go back to running different instances of the plug-ins other than multi timbral ones ?

Do others DAWS suffer the same; is this a Multi Core design thing ???

I'm really bummed out........

Thanks

VE Pro. Other than that, fewer multi-timbral and more single instances.
Old 19th September 2012 | Show parent
  #3
EDF
Gear Addict
 
1 Review written
🎧 10 years
Quote:
Originally Posted by EastWest Lurker ➑️
VE Pro. Other than that, fewer multi-timbral and more single instances.
Going to look in to that VE Pro, thanks for the heads up.
Old 19th September 2012
  #4
Lives for gear
 
🎧 10 years
VE Pro looks interesting and seems like a good platform and solution. However, i cant afford 2 systems or manage them in my small place.

Could i perhaps run the multi's on another DAW on the same system and rewire the outputs back into Logic ? Studio One maybe. Has anyone worked like this successfully.

Another simpler workaround i thought of is to use multitimbral VI's when composing without multi outputs. Then bouncing the individual tracks and use all audio tracks and channels for mixing. In some cases mixing within the VI's might be possible too. Kontakt, Maschine, Stylus have decent effects within them. I only need eq, comp and delays/verb for most stuff. The more channel strip dependent tracks could be bounced down as audio.

Its still annoying. We have such powerful machines these days. Pro software like LP should be able to utilize the power......
These technical ro*******s totally kill the creative flow.

Cheers
Old 19th September 2012
  #5
Gear Nut
 
Andl's Avatar
 
🎧 10 years
You can use VE Pro on your host computer. You don't need to have multiple machines, it's just an option.

I have the same problem with Logic and the eastwest Hollywood sample collections (8 core mac pro). VE Pro helps massively.

Another advantage is not having to wait for samples to reload every time you switch projects in logic.
Old 19th September 2012
  #6
Lives for gear
 
charlieclouser's Avatar
 
🎧 10 years
What Andl suggested is the way to go. Running VEPro on the same machine as your main DAW is basically the same as what you suggested about running the multis in another DAW on the same machine and rewiring them back into Logic - VEPro was specifically designed to do just that. No ReWire needed. It just works, and will alleviate most of the single-core issues with Logic. I can run stupendously large VEPro setups on one computer (8-core Mac Pro), much larger and more complex than would be practical with Logic alone. That said, if you're just using Logic alone, the solution to your problems is to run more single-instrument instances of Kontakt, Omnisphere, etc. instead of big multi-timbral instances. If you put Logic in 64-bit mode you can get pretty huge setups going with this technique.

Another side benefit of VEPro is that you can run Logic in 32-bit mode (to still use older plugins and avoid the 32-bit bridge), yet run the 64-bit version of VEPro, so when using leaky memory hogs like Omnisphere you can still scroll through patches without clogging. This is pretty fantastic stuff and VEPro has become the most widely used solution for seriously large setups. Do not be afraid that it looks a little strange - it's worth it for sure.

It is a simple matter to set up multiple "racks" of VEPro instances on a single computer, and with each "rack" you can choose individually whether or not you want the rack to stay in place when you switch songs in Logic, or have the loaded song in Logic tell the rack what instruments to load (the "preserve" function). This lets you have a bunch of racks that are always there (load them in the morning) to form the basis of your orchestra/band/template, and still have other racks that are "wild cards" that load individually for each song as you pull them up in Logic. It's pretty amazing how well-thought-out and thorough VEPro is. I have seen stupidly large setups that guys are using every day with no problems and total reliability.
Old 19th September 2012
  #7
Lives for gear
 
The Beatsmith's Avatar
 
🎧 15 years
Copy/past Kontakt instances and split the polyphony etc, i.e. use separate plugins for each thing
Old 19th September 2012
  #8
Gear Addict
 
Jimmy kiddo's Avatar
 
🎧 10 years
Quote:
Originally Posted by nyne ➑️
Just spent 2 nights creating an elaborate Multitimbral/Multi Output in Logic Pro 9. Had it set up with Maschine, Stylus RMX, Kontakt, Omnisphere, Guru, Nerve etc. All the multi audio outputs from plug-ins were routed through Aux channels. Upon loading some loops and patterns to make sure things were routed correctly i noticed that a single cpu core was spiking into red. Project stopped a few times due to overload error message.

I then did some search and found that Logic cannot distribute aux channels on separate cpu cores and that this issue was quite common and known.........

I am so disappointed. This is my main DAW, my livelihood, productivity depends on this. For a program which is known as a superior DAW for composers, this is a very strange issue......more so because the hardware we run it on is designed and manufactured by the same company!!!

Are there any workaround to this ?
How do u professional composers dealing with many Kontakts, Omnispheres etc work around this issue ?
SHould i just go back to running different instances of the plug-ins other than multi timbral ones ?

Do others DAWS suffer the same; is this a Multi Core design thing ???

I'm really bummed out........

Thanks
Can you tell us your computer specifications? I run huge projects with a lot vst multis in a Mac pro 8 core like nothing,.
One important tip : go to audio preferences (in logic)and choose whatever ammount of cores the system gives you, instead of automatic.
Old 19th September 2012
  #9
Lives for gear
 
🎧 10 years
imac 2.8 quad i7, os10.6.8

cpu has never been an issue, plenty juice here. thats why i'm annoyed at the logic cpu distribution issue. running multi outs on aux's brings a solid machine down by overloading a single core.

ve pro looks great.

sorry, typing on ipad and short on time.

thanks
Old 19th September 2012
  #10
Lives for gear
 
Alex Aliferis's Avatar
 
🎧 10 years
While this won't solve your issue, going to 'Logic Pro> Preferences> Audio> General' and unchecking "Display Audio Engine Overload Message" will prevent Logic from stopping playback whenever a sample can't be calculated in time for playback. This should relieve some headaches.
Old 19th September 2012
  #11
Lives for gear
 
valis's Avatar
 
1 Review written
🎧 15 years
Better yet, stop stacking plugins on the first set of auxes used for the VI outputs. You can do simple EQ etc there but those auxes are stacked on the same cpu as the VI itself for a reason, because this is Logic's approach to handling the first step for PDC using multi output VI's.

It's a hassle and semi cluttering to do what I suggest, but it eases the cpu burden. A better option of course is to do what others suggested for splitting the load on the VI frontend itself, but you still will do best by cascading your plugin loadout on auxes anyway.

Basically think of it like this:



Code:
Kontakt Main 1/2 > AudioInst Channel > aux/bus 9/10 [ Fx Chain ] >-----------------------------------Β¬
Kontakt Out 3/4 > aux/bus 3/4 > aux/bus 11/12 [ Fx Chain ] >-----------------------------------------|
Kontakt Out 5/6 > aux/bus 5/6 > aux/bus 13/14 [ Fx Chain ] >-----------------------------------------|
Kontakt Out 7/8 > aux/bus 7/8 > aux/bus 15/16 [ 1st Fx Chain ] > aux/bus 17/18 [ Fx Chain ] > -------|
                                                                                                     |
                                                                                               Aux/Bus 19/20 (group bus)
a
Old 20th September 2012
  #12
Lives for gear
 
🎧 10 years
Valis, thanks for the suggestion. I had heard of this trick before. So basically i should see the first set of Aux's as AUDIO THRU's and rout them to aux's where i would apply effects ?
Clutter could be managed by hiding the THRU's and setting them at 0db.

I am confused however. When a core was overloading on mine, i was running the following:
( All instruments were Multimbral so (INSTR x Digit) in the following means number of audio output channels (Auxs) for an instrument:

Maschine x 3, Kontakt x 3, RMX x 2, Omni x 3, Trill x 2, Nerve x 8 (single drum sounds) , Guru x 8 (Single drum sounds)

All outputs from individual instruments were routed to their own group master buses. At this stage i did not even have one insert effect on the aux channels.

As you can see it was not a very elaborate template and quite disappointing for me that it overloaded the system.

If i were to further route the individual aux outputs to yet another set of aux outputs and apply FX there, how would it solve the CPU issue, wont that be calculated above the CPU hit of the present state ?

I'll give it a shot.

Thanks

PS: Do other DAWS have the same CPU calculation design ? Trying to figure out if this is an OSX issue or a Logic issue.....

Regards
Old 20th September 2012
  #13
Lives for gear
 
valis's Avatar
 
1 Review written
🎧 15 years
There can be other reasons for cover overload too, that trick is simply to help distribute core load. You'll notice for instance the last output pair has TWO auxes cascaded to split the plugin load there.

But in the case of no external plugins causing cover overload you have the cases already given before:

Too much going on in a single Instance: I get this more with Kontakt instances that have MULTIPLE programs loaded, especially those with heavy scripts and/or internal Impulse reverbs and heavy internal processing etc. I also get core overloads with Guru when trying to run all engines with lots of parameter automation etc (btw you should check the guru options for a 'fix' that insures higher accuracy/sync to Logic's clock...if you didn't see that already. It's in the latest beta on the forums).

There are 2 other sources of issues too though, both related to 'live mode' in Logic running on the (last) single core always at a smaller buffer size. If your process buffer is set to medium I believe that Logic runs the 'mix' buffer at a 1024 buffersize to increase efficiency.

The reason it's important to understand this is because there's also the 'recording' latency buffer, which is the buffersize that audio objects use when they are in "live mode". So if you have a Kontakt or Guru instance that's percolating along just fine at 40% cpu usage at 1024 samples, and your 'recording' latency is set to 32 or 64 samples, throwing that VI into 'live mode' can quite easy overload the last core.

What enables live mode?
- Select a track to 'play it' (whether record armed too).
- Set a track's Live input monitoring switch to on (so that it can 'always be heard' whether VI or audio track).

My understanding is that VE Pro really mitigates having to worry about this, and even supports multiple machines. However on my 2008 era Mac Pro I'm still doing fine as long as I consider the things I've posted in this post and above. I do NOT do heavy orchestral work though, and would probably move to VE Pro for that before throwing money at a new Mac for Logic alone (since I could use an inexpensive PC with a VE Pro instance to be cost effective, etc).
Old 20th September 2012 | Show parent
  #14
Lives for gear
 
EastWest Lurker's Avatar
 
🎧 10 years
Quote:
Originally Posted by nyne ➑️
Valis, thanks for the suggestion. I had heard of this trick before. So basically i should see the first set of Aux's as AUDIO THRU's and rout them to aux's where i would apply effects ?
Clutter could be managed by hiding the THRU's and setting them at 0db.

I am confused however. When a core was overloading on mine, i was running the following:
( All instruments were Multimbral so (INSTR x Digit) in the following means number of audio output channels (Auxs) for an instrument:

Maschine x 3, Kontakt x 3, RMX x 2, Omni x 3, Trill x 2, Nerve x 8 (single drum sounds) , Guru x 8 (Single drum sounds)

All outputs from individual instruments were routed to their own group master buses. At this stage i did not even have one insert effect on the aux channels.

As you can see it was not a very elaborate template and quite disappointing for me that it overloaded the system.

If i were to further route the individual aux outputs to yet another set of aux outputs and apply FX there, how would it solve the CPU issue, wont that be calculated above the CPU hit of the present state ?

I'll give it a shot.

Thanks

PS: Do other DAWS have the same CPU calculation design ? Trying to figure out if this is an OSX issue or a Logic issue.....

Regards
It is a Logic issue. The developers goals where to make Logic able to open more plug-instances than other apps (which thy achieved) and they were not fans of the mutli-timbral workflow, which some of them considered a dated remnant of the days of less powerful computers with hardware tone modules and synths producing the sounds.
Old 21st June 2014
  #15
Gear Head
 
🎧 5 years
That's great this VE Pro. Will certainly buy this thing for sure. In the mean time I can share how I run multisampler without using aux in Logic, maybe it will help some of you. So the trick is simply to open one Multisampler like kontakt, using multi-instrument with multiple midi channels in the environment as usual, but send everything to one single audio output instead of multi-aux. When one track out of this multi instrument doesn't fit your mix properlly and need individual treatment, do this to bounce in place: select the midi notes you want to bounce, select "Function/transform/(any transform template)". Clic "hide unused parameter" so you un-hide them. Reset to virgin transformer and select instead "Channels: all => fix: (your current channel instrument, the one you want to bounce, ex: channel 4). This will force your midi notes to be using the midi channel you want, you can verify that your notes have changed midi channel by selecting "view/midi channel color" in the piano roll window. Then, you simply move the box containing your midi notes to the track containing the multi-intrument plugin, and do a regular "bounce in place". The whole process takes 3 to 5 seconds when you are used to it. Saves pain!
Hope this help!
πŸ“ Reply

Similar Threads

Thread / Thread Starter Replies / Views Last Post
replies: 504 views: 61794
Avatar for rids
rids 2nd November 2020
replies: 52 views: 6939
Avatar for pluto_ro
pluto_ro 4 weeks ago
Topic:
Post Reply

Welcome to the Gearspace Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…

Forum Jump
Forum Jump