The No.1 Website for Pro Audio
"Unable to locate Digidesign hardware" message fix!!
Old 10th January 2012
Registered User
🎧 10 years
"Unable to locate Digidesign hardware" message fix!!

Hey everyone!

I'm a longtime lurker at Gearslutz, but after discovering a fix to a seemingly common problem without an apparent solution I figured I would share it.

Since last November up until recently I was having some pretty major problems with PT. Everytime I would open up it up I got a message that said "Unable to locate Digidesign hardware. Please make sure it is plugged in or turned on then click ok". Long story short, I did everything I could find on Google short of completely reinstalling Pro Tools. I reinstalled the drivers, tried to manually point Pro Tools in the right direction via the Device manager, deleted my prefs...Heck, I probably even hit it a few times, but literally NOTHING was working. Frustrated I finally contacted Avid via email with one of their support code thingys. I sent my Mbox Mini in to get repaired, then when I got it back I opened the box, plugged it in, and got the same exact warning again. Feeling very exasperated at this point, I emailed Avid again to let them know, and they told me to call their technical support. I called them and talked to Connor, who linked our computers for about a half hour and fixed the whole problem! Here's what he did:

1.) User Account Control Settings: Go to "Control Panel" on the Start menu then click "User Accounts". At the bottom of the list in the center of the screen, you should see "Change User Account Control Settings". Click that then drag the slider down to "Never notify". Click "Ok" and close the window.

2.) Uninstall all Avid Mbox Drivers: Go to Control Panel again and click on "Programs and Features". You should see a list pop up that's populated with all of the programs on your computer. Locate the program that is labeled "Avid Audio Drivers". (Some of you may or may not have that installed on your computer. I think it depends on the version of PT you have or something like that). Also locate the driver icon for whichever model of Mbox you have. It will say something like "Avid Mbox *model* Driver (Without the asterisks obsiously). Uninstall both by hitting "Uninstall" at the top of program list. Windows will guide you through the rest. You may be prompted to restart at this point. I seem to have forgotten to take notes about that part...It's not a bad idea to restart though even if it doesn't prompt you too.

3.) Reinstall all Avid Mbox Drivers: Open your web browser and go to Click on "View Available Downloads" at the top of the page and download the one for windows. If you don't see an installer then go to your browser's download list and click the zipped folder icon. There should be an installer that will guide you through the rest. Make sure to restart after this too.

4.) Run as Administrator: This is probably the most important step out of all of them. After your computer restarts, right click on the Pro Tools shortcut on your desktop. If you don't have a short cut on your desktop, you should be able to drag a shortcut from the start menu or the Start bar to the desktop. After right clicking, click on the "properties" at the very bottom of the drop down menu. Click the "Shortcut" tab on the top of the window. Click "Advanced" at the bottom right, about 2/3rds of the way down. Click the check box that says "Run as administrator". Click "OK" to close the windows. Double click on the PT shortcut and PT will hopefully open right up!

This might not work for everyone, but it worked for me. I hope this helps a little! FYI, if you call technical support you might have to wait awhile. I waited 40 minutes on hold until I talked to someone.
Old 27th January 2012
Registered User
🎧 10 years
unable to locate....

Thank you very much! I have had same problems, searched for a fix and found your advice. I was able to fix with your step by step process awesome!! taking the time to share your fix is admirable!! john chiz
Old 17th July 2012
Registered User
🎧 10 years
Thank you so much for your help benjh1! You tha savior!!
Infinite respect & gratitude,
Old 20th December 2012
Registered User
🎧 10 years
I followed these steps as well, and it works. Thank you for your help. My other CPU crashed, and I already have my laptop as a backup with PT 8.05 installed. But this msg was really throwing me for a loop. All is well now. The PT might get confused if the other drivers are on there. This solution makes it so it only has run driver to read. Thank God!
Old 10th March 2013
Registered User
🎧 5 years
@benjh1 deserves an award for this post!!

Thank you for posting this @benjh1... You are a rockstar!

I put together my Pro Tools 8 LE studio about 2 years ago and have had wires running all over the place as I was adding components to it over time. I finally decided to shut everything down and rearrange my studio so all wires were concealed. Once I plugged everything back in and fired it all up, suddenly Pro Tools could not find my Avid Mbox!! Thank God I found this post!

I just followed your beautifully detailed directions and walla!! Everything is back to normal. However, the only thing that didn't work was the link to download the drivers, so here is another link to Avid's download page: Drivers for Avid Audio Hardware

For the person that may not know, when you go to the Avid download page, if you have an external Mbox, as I do, then you will need to click the "USB Device Drivers" link, a drop down menu will appear, then you can choose the drivers for your particular external Mbox unit.

Thank you again @benjh1 ~ YOU ARE A HERO!!
Old 29th March 2013
Registered User
🎧 10 years
Hey, thanks so much for this fix. It's saved me countless hours and dollars. I really appreciate you sharing this : )
Old 25th June 2013
Registered User
🎧 5 years
its not working :(

its not working ... please help .. i have a proo tools le 002 rak
what driver shoud i download from the downloads .... and where is the problem !!?
Old 15th August 2013
Registered User
🎧 5 years
awesome bro!

Thank you so much for that post... I've been trying to resolve this issue for two weeks. Appreciate your post.
Old 12th September 2013
Registered User
🎧 10 years
I'm glad this has helped so many of you guys! qutqut111, I hope you were able to work the situation out by now, but if not here's a link to the 002 and 003 driver pages: Digi 002 and 003 Drivers

Does this help?

I apologize for the broken link in my original post! Thanks Lunker for posting the correct link...
Old 18th April 2015
Registered User
🎧 5 years
Is mbox2 comparable with pro tools 8 HD?
πŸ“ Reply

Similar Threads

Thread / Thread Starter Replies / Views Last Post
replies: 179 views: 84403
Avatar for ZipSnipe
ZipSnipe 9th February 2017
replies: 173 views: 19688
Avatar for theblotted
theblotted 1st January 2009
replies: 15929 views: 1603834
Avatar for Ragan
Ragan 11th January 2019
Post Reply

Welcome to the Gearspace Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.

Slide to join now Processing…

Forum Jump
Forum Jump