Quantcast
MIDAS Venice F32 with Catalina 64bit - Gearspace.com
The No.1 Website for Pro Audio
MIDAS Venice F32 with Catalina 64bit
Old 12th September 2019
  #1
Here for the gear
 
🎧 10 years
MIDAS Venice F32 with Catalina 64bit

Hello from germany everyone,

does anyone have information about running the F32 console with MacOS Catalina?
I hope, the Thunderbolt to FW800 toFW400-Line will still work with this configuration.
Any ideas or answers?

Thanks,

Markus
Old 12th September 2019
  #2
Lives for gear
 
kuasalogam's Avatar
 
🎧 5 years
I think nobody knows the answer yet.
If your current system works without any problems, no need to upgrade the OSX
Old 7th October 2019 | Show parent
  #3
Here for the gear
 
🎧 5 years
Quote:
Originally Posted by kuasalogam ➑️
I think nobody knows the answer yet.
If your current system works without any problems, no need to upgrade the OSX
Unless you want to utilize the new features Catalina offers, then you do need to upgrade.
Old 7th October 2019 | Show parent
  #4
Lives for gear
 
Ol' Betsey's Avatar
 
1 Review written
🎧 15 years
Quote:
Originally Posted by Pradoosa ➑️
Unless you want to utilize the new features Catalina offers, then you do need to upgrade.
Unless the new features are more important than having a already working system you don't need to upgrade...
Old 8th October 2019 | Show parent
  #5
Lives for gear
 
kuasalogam's Avatar
 
🎧 5 years
Quote:
Originally Posted by Pradoosa ➑️
Unless you want to utilize the new features Catalina offers, then you do need to upgrade.
OS updates are never more important than an already stable and working system.
Old 8th October 2019
  #6
Lives for gear
 
🎧 15 years
A lot of DAW and plugin manufacturers are warning of issues with Catalina, so I definitely won't be upgrading until it's all ironed out.

https://cdm.link/2019/09/macos-catal...-what-to-know/
Old 16th November 2019
  #7
Here for the gear
 
🎧 5 years
i wanna check if somebody has check for the compatibility of the vf32 with the catalina?
Old 2nd December 2019
  #8
Here for the gear
 
Hello Guy !
I have Midas Venice F24 plug in to TB2>FW800>Midas
Im thinking on buying the new Mac Mini 2018...it have TB3 (USB-C)
There is anyone that work with the Venice F series with TB3?
Its work perfectly ?
Any issues ?

Thanks for the answers !
Great day!
Old 10th December 2019
  #9
Here for the gear
 
Anyone has it working yet.
Thinking myself of getting the new mac mini with Catalina.
Own a Venice F16 and would like to know if it runs on Catalina although I assume it will need a bit of fiddling to get it to work correctly.

Fingers crossed and TIA
Switec
Old 17th January 2020
  #10
Gear Nut
 
🎧 10 years
I've been curious myself since my 2011 MBP died and I had to get a new one. So in short it works! You have to use Apple TB3 to TB2, then a TB 2 to FW 800 and finally a FW 800 to 400 cable.
https://www.dropbox.com/s/wv4rtfws15...%20PM.jpg?dl=0
Old 9th February 2020
  #11
Here for the gear
Quote:
Originally Posted by stixnskin ➑️
I've been curious myself since my 2011 MBP died and I had to get a new one. So in short it works! You have to use Apple TB3 to TB2, then a TB 2 to FW 800 and finally a FW 800 to 400 cable.
https://www.dropbox.com/s/wv4rtfws15...%20PM.jpg?dl=0
I’ve had the exact same setup working with a 2019 MBP and Mojave but was afraid to upgrade to Catalina because of 64bit only and previous nightmare with Midas driver. Had to disable SIP before installing the driver. Took 3 attempts and specific adapters. You definitely have this setup working with Catalina?
Old 10th February 2020 | Show parent
  #12
Gear Nut
 
🎧 10 years
Quote:
Originally Posted by ungeeignet ➑️
You definitely have this setup working with Catalina?
So far so good. I mainly use the MBP with a 4848 now but was curious if my Venice F had become a boat anchor. I believe I downloaded the newest drivers and kept my fingers crossed. I was hoping to be able to multitrack live shows with it. If I remember correctly it didn't show up in the Apple audio setup but did in PT. I never went back to verify any particulars. I recorded some drums with an existing track. No problem. If there's something specific you'd like me to look into just ask. I'm not home right now but I'll check on what version of everything I'm using.


MBP 16" 2019
Catalina 10.15.2
2.3 Ghz core i9
32 gigs ram
Midas control panel 4.2.1

Last edited by stixnskin; 11th February 2020 at 07:25 PM.. Reason: update
Old 27th April 2020
  #13
Here for the gear
 
🎧 5 years
It works with Catalina for me with fw400 to fw800 to tb2
Old 29th May 2020
  #14
Here for the gear
 
I can also confirm that it works. New MacBook Pro 16. Installed the OSX driver by disabling SIP. It shows up in my Audio Devices.

My Venice F32 is connected to my mac via FW Cable - FW to Thunderbolt 2 dongle - TB2 to TB3 dongle (official Apple Dongles).

I only tested streaming of a stereo track on Channel 1&2 so far, as I still need to migrate my sessions. I would write an update if the rest of the channels wouldn't work.
Old 20th June 2020
  #15
Here for the gear
 
F16R Connectivity?

Hi all,
I'm actually running Mojave on a Mac Mini, sorry if I'm going a bit off topic. Since this seems to be one of the most recent threads about the Venice F series, I thought I'd give it a try anyway.

I got my F16R a few days ago and now I'm trying to make it work as an interface.

The setup:
F16R β€”> FW 400 Cable β€”> FW 800 Adapter β€”> TB2 Adapter β€”> Mac Mini running Mojave

I installed the latest driver from their site (3.5.6), connected everything, and powered up the Venice and computer in the order that their manual suggests.

The Problem:
I started the Midas Control Panel aaaaaaaaand: No devices found. Did a couple restarts, even de-installed and re-installed the drivers and still nothing.

The Mystery:
I checked the Firewire device tree in the system report and the Midas does show up. So the connection seems to be there. Anybody have any ideas? Thank you veryvery much!

Screenshots here: https://photos.app.goo.gl/B948zGpPMW1YGAYx8
Old 20th June 2020
  #16
Gear Nut
 
🎧 10 years
Are you using Apple cables and adapters? I've heard of problems with using other brands.
Old 21st June 2020 | Show parent
  #17
Here for the gear
 
Quote:
Originally Posted by stixnskin ➑️
Are you using Apple cables and adapters? I've heard of problems with using other brands.
the fw 800 β€”> tb2 is by apple while the fw 400 β€”> 800 is a third party product. looks like this wasn't part of the problem.

Somebody shared this in another thread and it WORKED :^)


1. Uninstall the current firmware.

2. Boot into OS X Utilities window, turn off SIP in Terminal and restart the machine.

3. Install the FW software again.

4. Boot into OS X Utilities window, turn on SIP

You should now be able to see the device in the Midas software.

Sorry for the inconvenience caused by this but as mentioned previously, this is a Legacy product."



Restart your Mac.
Before OS X starts up, hold down Command-R and keep it held down until you see an Apple icon and a progress bar. Release. This boots you into Recovery.
From the Utilities menu, select Terminal.
At the prompt type exactly the following and then press Return: csrutil disable
Terminal should display a message that SIP was disabled.
From the ο£Ώ menu, select Restart.
You can re-enable SIP by following the above steps, but using csrutil enable instead.
Old 13th November 2020
  #18
Here for the gear
works for me on Catalina

Hey fellow Midas F32 users,

my F32 works perfectly with Catalina, the path is:

MacBook Pro 2017 USB C Port -> OWC Thunderbolt 3 dock -> Firewire 800 to Firewire 400 adapter -> Midas F32

Before, it was running perfectly under Sierra, High Sierra and Mojave.
I installed Catalina a couple of months ago, didn't have to change any settings, it just worked. Besides some minor software issues it's the most stable system I have ever been working on.

Now let's hope it will work on Big Sur too, but as long as the audio software manufacturers haven't adopted (I guess it will take a year?!) it's not really an issue anyway.

If anybody gets a Midas F32 working on a Mac with Big Sur, please let us know!
Old 27th November 2020
  #19
Here for the gear
 
Hey guys,

Just recently bought an F-32 and trying to connecting my mac through firewire.

The midas control panel keeps recognising the F32 and it will let me select it as an audio output in sound preferences but as soon as I try and play anything through it the connection will drop out.

Has anyone experienced this and fixed it by any chance? Wondering whether it is a power issue as the Midas didn't come with the original cable or whether it's down to the software.

Any help is greatly appreciated
Old 30th November 2020
  #20
Here for the gear
 
🎧 5 years
I didn't manage to get it work with Big Sur and got a reply from Musictribe, that it will not be supported :(
πŸ“ Reply

Similar Threads

Thread / Thread Starter Replies / Views Last Post
replies: 1042 views: 297553
Avatar for kings
kings 1 week ago
replies: 166 views: 52417
Avatar for kings
kings 19th May 2021
replies: 83 views: 10469
Avatar for James Lehmann
James Lehmann 3rd February 2017
replies: 11 views: 4348
Avatar for kings
kings 16th August 2019
Post Reply

Welcome to the Gearspace Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…

Forum Jump
Forum Jump