Quantcast
New Echo Audiofire Mac driver released this week - Gearspace.com
The No.1 Website for Pro Audio
New Echo Audiofire Mac driver released this week
Old 17th January 2019
  #1
Lives for gear
 
🎧 10 years
New Echo Audiofire Mac driver released this week

Echo Audio have just released Mac OSX 10.11 (El Capitan) drivers within the last few days for their Audiofire range....for anyone who's interested: Downloads - Mac OS X Software | Echo Digital Audio

Released on 15th Jan 2019, it's version 5.91
The Audiofire interfaces haven't been produced for several years, but this is a welcome release for those who still use them, even if they aren't listed as compatible with contemporary Mojav OSX.
Kudos to Echo tech support
Old 17th January 2019
  #2
Lives for gear
 
🎧 10 years
That's great to hear! Given that Echo no longer makes audio interfaces, anything should be considered a bonus at this point.
Old 18th January 2019 | Show parent
  #3
Lives for gear
 
🎧 10 years
Quote:
Originally Posted by 12Bass ➑️
That's great to hear! Given that Echo no longer makes audio interfaces, anything should be considered a bonus at this point.
I'm now on Yosemite 10.10.5 and the new driver is apparently crafted for the 'next' OSX (El Capitan)10.11.....but I'm not inclined to change to that OSX. I wonder if I'd gain anything by updating to the newly released driver....just because it's new ?
Old 31st January 2019
  #4
Gear Nut
 
🎧 10 years
I have Audiofire 2 on Mac os Sierra - new 5.9.1 driver produces error ("no fireworks3 file on path"). Previous 5.9 with old GUI still works.
Old 1st February 2019 | Show parent
  #5
Lives for gear
 
🎧 10 years
Quote:
Originally Posted by cltd ➑️
I have Audiofire 2 on Mac os Sierra - new 5.9.1 driver produces error ("no fireworks3 file on path"). Previous 5.9 with old GUI still works.
It's interesting that Echo Audio only upgraded their driver to El Capitan status, and didn't go further to embrace Sierra, High Sierra or Mojave. I wonder if they ran into the same problems identified in this thread : MBP High Sierra and Mojave CoreAudio overload bug

If you can take the trouble to contact Echo support via their website's contact page, it would probably help them to fix it for yourself and others
Old 11th May 2019
  #6
Here for the gear
 
Hello, hate to bump this but I was given an audiofire 4 and happen to have an iMac with yosemite OS X. Having trouble getting to work with garageband, any help would be very helpful. I downloaded 5.9 from echos website and it's not recognizing the interface at all.

Thanks!
Old 13th May 2019
  #7
Lives for gear
 
🎧 10 years
Kingsley it's worth also downloading the Audiofire manual from the Echo site, as that may have additional help for your situation, and Echo support are helpful (email via website)
Old 19th May 2019
  #8
Here for the gear
 
Finally I get to try out my old audiofire 2 – but the new app simply refuses to open a window on my mojave machine. It runs, but I cant use it without any gui.

Anyone else encountered this?
Old 20th May 2019
  #9
Gear Head
 
🎧 10 years
I still have my AudioFire 4 working on a Mavericks machine. On the About page, it states that the console version is 5.7.6. When I just looked at the download page at the Echo website it skips from 5.7.1 to 5.9. I don't know if I have an updated version that is no longer available? Anyway, I do remember a few years ago trying to update the console and ruining my day. I reverted back and no problems since. I will be sad to see this thing go, it is easily the best audio purchase I have made considering price and total usage, just amazing.
Old 25th July 2019 | Show parent
  #10
Here for the gear
 
🎧 5 years
Quote:
Originally Posted by mrhat ➑️
Finally I get to try out my old audiofire 2 – but the new app simply refuses to open a window on my mojave machine. It runs, but I cant use it without any gui.

Anyone else encountered this?
Yes, i get sound, but no GUI on Macbook pro 2018, Mojave. Have you found any workarounds for this?
Old 30th July 2019 | Show parent
  #11
Here for the gear
 
🎧 5 years
Quote:
Originally Posted by swedemason ➑️
Yes, i get sound, but no GUI on Macbook pro 2018, Mojave. Have you found any workarounds for this?
I'm also on Mojave and had the same problem.

Try this...

Go to Applications -> Right-click on "Echo Firewire Console" App -> Click "Show package contents" -> Open folder "Contents" -> Open folder "MacOS" and launch "Echo FireWire Console" file by clicking on it. It opens Terminal and console UI.

Hope it helps
Attached Thumbnails
New Echo Audiofire Mac driver released this week-echo.png  
Old 2nd August 2019 | Show parent
  #12
Here for the gear
 
🎧 5 years
Quote:
Originally Posted by lektro ➑️
I'm also on Mojave and had the same problem.

Try this...

Go to Applications -> Right-click on "Echo Firewire Console" App -> Click "Show package contents" -> Open folder "Contents" -> Open folder "MacOS" and launch "Echo FireWire Console" file by clicking on it. It opens Terminal and console UI.

Hope it helps
Bah, it still doesn't work for me unfortunately. Console opens but still no GUI. Its a great little interface which has served me well. I really dont wanna have to bin it, and Ive already forked out 50 QUID for a thunderbolt-usb c dongle to daisy chain into my firewire-thunderbolt dongle. I wish i didnt use Logic
Old 2nd August 2019
  #13
Lives for gear
 
🎧 10 years
Send an enquiry to Marcel (if he's still there) at Echo Audio support...and please post the solution here, if he's able to give you one: https://echoaudio.com/pages/contact-tech-support
Old 2nd August 2019 | Show parent
  #14
Here for the gear
 
🎧 5 years
done, will get back soon as
Old 17th February 2020
  #15
Here for the gear
 
🎧 5 years
No news, i guess?
Old 10th March 2020
  #16
Here for the gear
 
🎧 5 years
nope.
Old 10th March 2020
  #17
Here for the gear
 
🎧 5 years
although i just got it working using sir Lektros method. When it crashes, click reopen application and the gui should appear. Check keep in dock and you're sorted.
Old 18th June 2020
  #18
Deleted 4d80fd1
Guest
I've actually just spent a fair amount of time today and last month upgrading my OS's to see what my Echo 8 & 12s could handle. I have 4 echos chained together and several HDs with different OSs to experiment with before I upgrade my main HD.

So I got console software 5.9 working with High Sierra fine but it stops at Mojave. That said the audio still records in Mojave I just can't adjust my monitors with the Console software as it won't open.

Today I tried to upgrade to 5.9.2 and 5.9.4 and while everything upgraded fine I could no longer get my aggregate device to work on any on either 10.13 or 10.14. I also gave my MBP which is now on Catalina a try and nothing worked.

I may give it a try again. But for now I'm staying at High Sierra and Console 5.9.
Old 19th June 2020
  #19
Here for the gear
 
🎧 10 years
Echo Audio has just released, in June 2020, console software 5.9.4 which is compatible with all MAC OS X versions, Catalina included!

Last edited by saro; 20th June 2020 at 12:59 AM.. Reason: Adjust words to be clearer
Old 20th June 2020 | Show parent
  #20
Lives for gear
 
🎧 10 years
Quote:
Originally Posted by syzygywell ➑️
I've actually just spent a fair amount of time today and last month upgrading my OS's to see what my Echo 8 & 12s could handle. I have 4 echos chained together and several HDs with different OSs to experiment with before I upgrade my main HD.

So I got console software 5.9 working with High Sierra fine but it stops at Mojave. That said the audio still records in Mojave I just can't adjust my monitors with the Console software as it won't open.

Today I tried to upgrade to 5.9.2 and 5.9.4 and while everything upgraded fine I could no longer get my aggregate device to work on any on either 10.13 or 10.14. I also gave my MBP which is now on Catalina a try and nothing worked.

I may give it a try again. But for now I'm staying at High Sierra and Console 5.9.
Note that, in the release Readme file for June 2020 version 5.9.4, it states:

"Supported Operating Systems and Hardware
This release supports macOS 10.10 through macOS 10.15.

Note that on macOS 10.14 or later, you will be prompted to allow the Echo FireWire Console to access the camera. While this may seem odd, be sure to select OK. Otherwise, the FireWire Console will be unable to control your AudioFire"
Old 20th June 2020 | Show parent
  #21
Deleted 4d80fd1
Guest
Quote:
Originally Posted by studer58 ➑️
Note that, in the release Readme file for June 2020 version 5.9.4, it states:

"Supported Operating Systems and Hardware
This release supports macOS 10.10 through macOS 10.15.

Note that on macOS 10.14 or later, you will be prompted to allow the Echo FireWire Console to access the camera. While this may seem odd, be sure to select OK. Otherwise, the FireWire Console will be unable to control your AudioFire"
I did that one the 10.14 HD and I couldn't get audio to work on either OS not Mojave or High Sierra. I had to roll it back.
Old 28th June 2020
  #22
Here for the gear
 
🎧 5 years
dug my old audiofire2 out today, so glad to see echoaudio still making drivers still for this. just tried the most recent driver with mojave and its working
Old 10th July 2020 | Show parent
  #23
Gear Head
 
somant's Avatar
 
🎧 10 years
Quote:
Originally Posted by dan_tmtk ➑️
dug my old audiofire2 out today, so glad to see echoaudio still making drivers still for this. just tried the most recent driver with mojave and its working

Ha, same here - just got it out and it works brilliantly (as it always did).

Thanks Echo! Great support! Would have been a pity to put the thing in the attic.
Old 27th July 2020
  #24
Gear Addict
 
🎧 10 years
In the market for a 10 input audio interface for my IMac Pro on Catalina...So is this now a safe bet??
Old 3rd July 2021
  #25
Gear Maniac
 
sdmc303's Avatar
 
🎧 5 years
I keep getting INVALID FILE TYPE when attempting to download current/latest drivers for mac 10.14..
Anyone else experiencing this?
Old 3rd July 2021 | Show parent
  #26
Gear Maniac
 
sdmc303's Avatar
 
🎧 5 years
Quote:
Originally Posted by dan_tmtk ➑️
dug my old audiofire2 out today, so glad to see echoaudio still making drivers still for this. just tried the most recent driver with mojave and its working
Still working?
πŸ“ Reply

Similar Threads

Thread / Thread Starter Replies / Views Last Post
replies: 162 views: 59439
Avatar for .Russ.
.Russ. 19th July 2013
replies: 29 views: 3157
Avatar for whinecellar
whinecellar 12th November 2008
replies: 68 views: 27029
Avatar for Sweet Square
Sweet Square 7th December 2017
replies: 2429 views: 423446
Avatar for esldude
esldude 8 hours ago
Topic:
Post Reply

Welcome to the Gearspace Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…

Forum Jump
Forum Jump