Quantcast
Focusrite Saffire Pro 40 Drivers - Gearspace.com
The No.1 Website for Pro Audio
Focusrite Saffire Pro 40 Drivers
Old 10th February 2009
  #1
Gear Nut
 
🎧 10 years
Unhappy Focusrite Saffire Pro 40 Drivers

I just got mine from germany, and the installation is just impossible!
Not exaggerating!

the driver that came along with the package, is old (and wont do anything)
the driver that can be downloaded from the focusrite support pages, yeah, it runs the software, but there is no sync between the saffire hw & sw.

Anyone else facing problems like this?
Help please!!

And i can't find a proper installation guides aswell.
Just a dumn one page a4 that basicly says "this is how things should go..good luck.."
Old 10th February 2009
  #2
Lives for gear
 
Iggy Poop's Avatar
 
🎧 10 years
Quote:
Originally Posted by sguali ➑️
I just got mine from germany, and the installation is just impossible!
Not exaggerating!

the driver that came along with the package, is old (and wont do anything)
the driver that can be downloaded from the focusrite support pages, yeah, it runs the software, but there is no sync between the saffire hw & sw.

Anyone else facing problems like this?
Help please!!

And i can't find a proper installation guides aswell.
Just a dumn one page a4 that basicly says "this is how things should go..good luck.."
I can't help you with this but thanks for the heads up on it because I was considering buying it against the Profire 2626.
Old 11th February 2009
  #3
Gear Maniac
 
1 Review written
🎧 10 years
You know, I absolutely love my Saffire Pro, it sounds great, works great, and has tons of options....but the drivers are complete junk! They need to update them again.
Old 11th February 2009 | Show parent
  #4
Gear Nut
 
🎧 10 years
I havent got that far yet. I guess i have to send the poor thing back to germany..Its just dumn when something that you have been waiting a while, is not what you thought it would be..=/
Old 11th February 2009 | Show parent
  #5
Gear Maniac
 
1 Review written
🎧 10 years
When I installed mine the many times, it has an install step by step thing that has you plug it in at a certain time and all that jazz. Once I installed everything doing the steps it said, it worked for me. But if I didn't do the steps right, I was screwed. Sorry to hear about your problem, don't let it frustrate you. The preamps on these things are great!
Old 11th February 2009 | Show parent
  #6
Gear Maniac
 
🎧 10 years
You got other firewire gear before ? 'cause it may be a compatibility issue , I got quite the same issues with another firewire gear on a onboard controller.

My saffire pro 40 is working quite fine for now, never had a problem with it.
Old 11th February 2009 | Show parent
  #7
Gear Nut
 
🎧 10 years
I got my self almost a 70€ firewire PCI-E card, so that the change of screw ups would be low as possible..Little i knew..

My system founds the firewire card, AND the saffire pro 40 from the device management, but the Saffire Mix Control (1.2) says that the device is disconnected.

Thanks to RevoltStudios. Kind words.
Old 11th February 2009 | Show parent
  #8
Gear Maniac
 
🎧 10 years
Are you aware of this issue :

Faulty firewire cables. .: Focusrite Answerbase

And also, did you test another device on your PCI-E card ? Because when my firebox was completely lost, it was well recognize by window, but did only ****.

By the way, which OS are you using ?

If I was in your case, I would definitely want to be sure if the unit or the PC is faulty, because if not, you won't be sure that another unit won't do the same again ...

Can't you access another PC to test the unit on ? Or another firewire audio unit to test on your PC ?
Old 11th February 2009 | Show parent
  #9
Gear Nut
 
🎧 10 years
Thanks for the list. The cable im using was not listed on the fault list.
I think i have to wrap the saffire up from the rack and call in a few favs.

But if the device works in an other computer..That will lead me in to a mess im not sure i want to be a part of.

firewire interface,Mother board, irq settings...awwhss**** i can imagine the bit jungle.

I do computer programs and web pages for living, but for a long time im having second thoughs of doing something with computers..

And as for the version...(this is embarrassing)

Win XP home SP 2 Verison 2002.

ouch. there. I said it.
Old 23rd February 2009 | Show parent
  #10
Here for the gear
 
🎧 10 years
Hey mate, I just bought a bog standard Saffire model and had similar issues. Yeah, the software in the box didn't work as it didn't match the firmware version of the unit (you'd think they'd at least get that right!). Once working I also had all sorts of sync issues (after dowloading new drivers/software first). If you're lucky enough to be running XP with SP2 or SP3 there is a high possibility you'll have problems with the firewire speed as Microsoft kindly dropped speed back to 100 instead of 400/800 (there are various conspiracy theories about this). Anyway if this is the issue you need to dload and run a hotfix as it doesn't come up in usual updates. Visit the Focusrite page re optimising for Win XP -
Optimising your PC for Audio on Windows XP .: Focusrite Answerbase
This will point you to Microsoft site where you can download respective hotfix depending on whether you have SP2 or SP3. This fixed my sync issues straight away and also my missing midi ports started to work.
Still some issues with drivers clashing with my MB sound drivers (Realtek) though.
Hope this helps. Saffire sounds great, shame about the dodgy drivers/packaging
πŸ“ Reply

Similar Threads

Thread / Thread Starter Replies / Views Last Post
replies: 50 views: 46018
Avatar for anilnc
anilnc 23rd June 2011
replies: 2380 views: 409578
Avatar for didier.brest
didier.brest 3 weeks ago
Post Reply

Welcome to the Gearspace Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…

Forum Jump
Forum Jump