EMU Audity 2000 - Gearspace.com
The No.1 Website for Pro Audio
EMU Audity 2000
Old 5th April 2008
Here for the gear
🎧 10 years
EMU Audity 2000

Hi I'm new here so not sure if this is the right place to post this...

I have an EMU AUDITY 2000 that isn't well, it is on OS 2.01 and when you switch it on it says "Searching for OS...".

I have found that if I press and hold down CLOCK & SAVE/COPY when I switch it on that it will boot normally, however I would like to be able to fix it. Does anyone out there know how to do this?

Having changed the internal battery and tried to reinstall the OS using the OS9 EMU OS Loader and still not got around this issue.

I run an 8 Core Mac Pro and so booting into OS9 is a no go for me these days. I wondered if its fubar or if it can be risen from the synth dead? I would semd it to the Synth Service Centre but the cost of repair outweighs the cost of the unit itself. I'm pretty handy with a soldering iron and OS systems. I'm just not sure where to start and EMU don't know how to help these days as they are all about selling PC sound cards.
Old 6th April 2008
Gear Maniac
oortnyc's Avatar
🎧 15 years
I have the exact same issue. I searched around and was not able to find a solution.
If you find out anything please let me know.

Thanks -

D -
Old 6th April 2008 | Show parent
Here for the gear
🎧 10 years

So its not just me then!


I've tried the EMU, A2K Yahoo user group and SOS Forum. Still haven't found an answer to this one.

If I ever find one I'll let you know.
Old 8th April 2008 | Show parent
Here for the gear
🎧 10 years
Anyone out there have an idea where we could look?

Google has yet to shed any light on this issue unfortunately.

So I need some other places I could look for help.
Old 10th April 2008 | Show parent
Here for the gear
🎧 10 years
Old 26th April 2008 | Show parent
Here for the gear
🎧 10 years
Old 2nd February 2009
Here for the gear
digian's Avatar
🎧 10 years
E-mu Audity 2000 rescue

Hi all of you,

I'm new to this community because of your thread on the E-mu Audity 2000. Mine has died too. I would like to make an effort in trying to bring it back alive (since it's a great synth). I do have full access to Mac OS9.x but do not have the E-loader software or any specific or system files for it. So if anyone could provide me with these by mail I would be too happy to start and try to find "a cure" for the "searching for OS" message at startup.
Old 10th November 2009 | Show parent
Here for the gear
🎧 10 years
I am also having this problem. Thankfully, my changes to patches dont get wiped out with holding the clock/copy buttons down.

I even asked a friend who used to be a EMU tech support guy, and he had not seen this problem, and did not know what to do except for cleaning the contacts for the ROMS and/or replacing the battery. He did tell me that Creative Labs moved all hardware parts/repaires to a 3rd party service center in Florida, so i am contacting them now. I will post if i find out anything more.
Old 21st May 2018
Here for the gear
🎧 5 years
I realize this thread is ANCIENT, but I just recently "repaired" my Audity 2k that was experiencing the same issue... I thought I shed some light on my dilema and the fix(es)...

First off, as many of you have done, I replaced the NVRAM battery (not exactly the easiest task, since Walgreens and CVS don't carry the litium battery used.. I had to locate and order a BR2335 battery from online - not horrible, but not easy and quick...)

Once that was done, I decided the next step was to try to upload the v2.01 firmware - This is the part where I lucked out... I managed to have squirrelled away an old WinXP PC that I could use with the EMU E-Loader 1.1 software. With the WinXP OS, the E-Mu loader software and manual, and an EMU 1x1 USB-to-Midi cable in my hands, I was able to revive the old girl.

Pro Tip: Make sure that when you start up the Audity 2k, that you follow the instructions and boot it by holding down the Clock+Enter buttons...

All that being said, your Audity must already be on v2.0 or v2.01 before you are able to re-load the firmware. From what I understand, v1.0 doesn't have the ability to be upgraded or over-written like v2.x can. If you are unsure what version you are currently on, you can hold down the Clock+Save buttons during power up and you should be able to verify the firmware version.

If you aren't lucky enough to still have a WinXP PC, if you search in the right dark-corners of the internet, you should be able to find install disks or virtual versions that can be loaded and used with VirtualBox.

I hope that helps a little or at leaast gives some trepid techy souls a little hope.
Old 11th August 2020
Here for the gear
Possibly related Audity 2000 problem


I also had the problem with the NVRAM and the battery but does anyone know why my arpeggiator isn't working? Is it a related problem. I have the owners manual and have followed it to the letter but can't get any arpeggios going.

One small thing, the display in the manual doesn't look EXACTLY the same as on the device.

Any help would be great!


Old 27th September 2020
Deleted 5a55dd9
A different Audity 2000 question I hope someone can answer

I know the 2000 series ROMS won't work in the Audity, but can it work the other way around

Can I remove the 2 Roms inside an Audity (the original Audity Rom and the Xtreme Expansion Rom) to use in a Proteus 2000 ?

πŸ“ Reply
Post Reply

Welcome to the Gearspace Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.

Slide to join now Processing…

Forum Jump
Forum Jump