Quantcast
Genelec 1031A troubleshooting - Gearspace.com
The No.1 Website for Pro Audio
Genelec 1031A troubleshooting
Old 17th August 2017
  #1
Gear Maniac
 
🎧 15 years
Genelec 1031A troubleshooting

Hey guys,

I have Genelec 1031A monitor that is going bad. I've had these since about '98 and they still sound great, but recently one of them is intermittently making loud hiss/waves sound and not passing audio. Eventually the hiss fades out and the speaker comes back online. When it works, it sounds great.

Wondering if that sounds like a power supply issue, or an issue with the amp itself. These aren't my main monitors, and I'd like to avoid sending these to Genelec and paying a chunk of $$$ to fix.

Any wisdom from those smarter than me?

Thanks!

Kent
Old 19 hours ago
  #2
Lives for gear
 
s.d.finley's Avatar
 
🎧 15 years
Hey there! I am in the same boat with a 1031a. Were you able to fix the monitor?
📝 Reply
Topic:
Post Reply

Welcome to the Gearspace Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…

Forum Jump
Forum Jump