Quantcast
MFB Dominion 1 - Page 54 - Gearspace.com
The No.1 Website for Pro Audio
MFB Dominion 1
Old 6th April 2016
  #1591
Here for the gear
 
🎧 5 years
Oh huh, that's a relief!

Cannot test mine now, but hopefully I can resurrect Dom1 tomorrow!
Old 7th April 2016
  #1592
Gear Nut
 
🎧 10 years
Would be nice also if a german user could translate the pdf with complete list of bug fixes and add on so we can take a closer look. Tried google translate but he gets kind of messy. Thanks in advance
Old 7th April 2016
  #1593
Gear Head
 
🎧 5 years
Is there any way to restore the factory presets? I got my Dominion 1 today and accidentally saved over a couple I liked and wanted to dissect...that's what I get for trying to decipher the German manual.
Old 7th April 2016 | Show parent
  #1594
Gear Nut
 
🎧 10 years
Quote:
Originally Posted by Atomicunderware ➡️
Is there any way to restore the factory presets? I got my Dominion 1 today and accidentally saved over a couple I liked and wanted to dissect...that's what I get for trying to decipher the German manual.
if you get this latest update there is a sysex file called Dominion 1 - Factory Sounds.syx
Old 7th April 2016 | Show parent
  #1595
Gear Head
 
🎧 5 years
Quote:
Originally Posted by hugo leitao ➡️
if you get this latest update there is a sysex file called Dominion 1 - Factory Sounds.syx
Thanks, I'll give it a go tomorrow.
Old 7th April 2016
  #1596
Here for the gear
 
🎧 5 years
Success!!

Being impatient of nature I just had to try my luck and install the OS via MIDIOX (Windows) using a Scarlett 2i4 interface not knowing where the journey would take me. So for all the Windows users (especially newbies to MIDIOX like me) here's what happened:
I played back the new OS file (1.18a) in MIDIOX (a MIDI file player provided by MIDIOX is used for that, and there's no option to set buffer sizes or delay times, you just play the file). Nothing happened
I looked at the settings of MIDIBar (the MIDI player) and changed the MCI port select from default to my interface.
Played the file again, my Dom lights up like crazy and about a second later it tells me ERROR Please install OS
Turned the DOM off and on again: same error message
Played the MIDI file again and the DOM now tells me "Updating, do not turn off!!!", no error message shows up during the 4:52 minutes that MIDI file is playing.
And voila OS 1.18 installed

Hope I could help other Windows users out there. It now seems safe to update with both systems, although the initial error message gave me a good scare, looked like I had messed up the OS. Off to trying out the new features.
Old 7th April 2016 | Show parent
  #1597
Here for the gear
 
🎧 5 years
Quote:
Originally Posted by hugo leitao ➡️
Would be nice also if a german user could translate the pdf with complete list of bug fixes and add on so we can take a closer look. Tried google translate but he gets kind of messy. Thanks in advance
Here you go... hope this makes sense to you

! DISCLAIMER - This is an unofficial translation and it´s probably faulty !


Changes in 1.18

- after switchin on sequence 1 can be launched without selecting
- after switching on tempo will now be properly send to keyboard controller (280 Bug)
- after switching on ATModAmount will be properly fetched
- while programming a sequence ATModAmount will be internally set to max, so AT can be usefully programmed
- ATModAmount controller can now be used during sequence playback
- Glide controller can now be used as amount controller during sequence playback
- fully turned to the left: programmed glide has no effect
-fully turned to the right: programmed glide has maximum effect
- after stopping the sequencer aftertouch will be reset to 0 (previously lasr AT-value stayed active)
- when activating Arp/Seq-functions: Range, Direction, Shuffle and Record - the currently selected value from the menu will be detached from the potentiometer (previously it was possible that for instance while modifiing shuffle the midi channel would have been changed as well)
- when doing a reset (shift + enter) only velocity values will be reset
- if an active patch is modified with SysEx, changes will be instantly in effect
- S&H LFOs will generate noise at maximum rate (random generator reworked so it now avoids periodicity)
- new link mode: in this mode every sequence will activate a corresponding patch (e.g Seq 7 -> Patch 7). To activate linkmode hold "Patch" down and then press "Seq/Arp" or hold "Seq/Arp" down and then press "Patch"
-when linkmode is activated Arp will be switched to Seq internally if necessary
-if linkmode is activated, Patch- Seq/Arp LEDs will light up
- when selecting a sequence/patch in linkmode, the patch will be active instantly, but a sequence will wait until the last note of the current sequence
- to deactivate linkmode hold "Patch" down and then press "Seq/Arp" or hold "Seq/Arp" down and then press "Patch"
- if in linkmode the manual patch is chosen, linkmode will be deactivated, because there is no manual sequence
- linkmode can be activated and deactivated while the sequencer is running

! DISCLAIMER - This is an unofficial translation !
Old 7th April 2016
  #1598
Here for the gear
 
🎧 5 years
I absolutely second the translation of Spiral Sun, it's pretty much spot on! Great service to the community. Nice first post
Old 7th April 2016
  #1599
Lives for gear
 
Paradigm X's Avatar
 
🎧 10 years
interesting sounding additions...
Old 7th April 2016 | Show parent
  #1600
Here for the gear
 
🎧 5 years
Quote:
Originally Posted by tripbeat ➡️
hi, i uploaded new file at our webside. should work now.
settings for SysEx Librarian:
- Pause between played messages: 1 second
- Transmit Speed 323 Bytes/sec (10%)
lemme know
IT'S ALIVE!

With these settings the update went through. Danke schön!
Old 7th April 2016
  #1601
Gear Nut
 
🎧 5 years
Yeah! Thanks for the help Tripbeat!
Updating!
Note : when I first tried to upload the update to my Dominion 1, I used 1% transmit speed.
It seems to me that too high transmit speed but also too low ones can make the update failing.
Old 7th April 2016
  #1602
Lives for gear
 
🎧 5 years
Sounds like there's a lot of good usability updates! Enjoy the synth folks, I'm still GASing here
Old 7th April 2016 | Show parent
  #1603
Gear Nut
 
🎧 5 years
Quote:
Originally Posted by tripbeat ➡️
hi, i uploaded new file at our webside. should work now.
settings for SysEx Librarian:
- Pause between played messages: 1 second
- Transmit Speed 323 Bytes/sec (10%)
lemme know
worked for me , SysEx librarian and Saffire Pro40

thanks
Old 7th April 2016
  #1604
Gear Nut
 
🎧 5 years
So happy to have my D1 up and running again.
I even did not lose my presets, super happy with that!
The bugs I've found are all fixed in this update except one, but I may be mistaken :
Using RETRIG mode, AMP EG is not retriggered when playing legato, only FILTER EG.
I would have liked to have LFO MIDI sync but hey, great job on this update, it is a nice one.
Best monosynth ever.
Old 7th April 2016 | Show parent
  #1605
Gear Nut
 
🎧 10 years
Quote:
Originally Posted by Spiral Sun ➡️
Here you go... hope this makes sense to you

! DISCLAIMER - This is an unofficial translation and it´s probably faulty !


Changes in 1.18

- after switchin on sequence 1 can be launched without selecting
- after switching on tempo will now be properly send to keyboard controller (280 Bug)
- after switching on ATModAmount will be properly fetched
- while programming a sequence ATModAmount will be internally set to max, so AT can be usefully programmed
- ATModAmount controller can now be used during sequence playback
- Glide controller can now be used as amount controller during sequence playback
- fully turned to the left: programmed glide has no effect
-fully turned to the right: programmed glide has maximum effect
- after stopping the sequencer aftertouch will be reset to 0 (previously lasr AT-value stayed active)
- when activating Arp/Seq-functions: Range, Direction, Shuffle and Record - the currently selected value from the menu will be detached from the potentiometer (previously it was possible that for instance while modifiing shuffle the midi channel would have been changed as well)
- when doing a reset (shift + enter) only velocity values will be reset
- if an active patch is modified with SysEx, changes will be instantly in effect
- S&H LFOs will generate noise at maximum rate (random generator reworked so it now avoids periodicity)
- new link mode: in this mode every sequence will activate a corresponding patch (e.g Seq 7 -> Patch 7). To activate linkmode hold "Patch" down and then press "Seq/Arp" or hold "Seq/Arp" down and then press "Patch"
-when linkmode is activated Arp will be switched to Seq internally if necessary
-if linkmode is activated, Patch- Seq/Arp LEDs will light up
- when selecting a sequence/patch in linkmode, the patch will be active instantly, but a sequence will wait until the last note of the current sequence
- to deactivate linkmode hold "Patch" down and then press "Seq/Arp" or hold "Seq/Arp" down and then press "Patch"
- if in linkmode the manual patch is chosen, linkmode will be deactivated, because there is no manual sequence
- linkmode can be activated and deactivated while the sequencer is running

! DISCLAIMER - This is an unofficial translation !
Great. MFB is a small company and they are always quite busy. Thanks
Old 7th April 2016
  #1606
Gear Nut
 
🎧 5 years
Noise as modulation source is a great addition, and has been well implemented (Using the S&H LFO shape)
Old 7th April 2016
  #1607
Gear Addict
 
The Lurcher's Avatar
 
🎧 5 years
Hey all really glad that the update problem has been fixed!!
Now for the embarrassing bit - as much as I have owned and used analog synths over the last 35 years I am a complete newbie in regards to sysex / midiox etc. so am concerned about doing the update. I have midiox (am on PC not Mac) and the correct interface midi leads etc. Have used it once to update the OS on my Pro 2 but DSI sent me idiot proof instructions on what to do and it went smoothly. I am not useless with computers, used them for many years but just have no experience with midiox and I just don't want to cock this up!
I'm kinda hoping that one of you out there has the patience to put an idiot proof list of how exactly to do this. Obviously I have opened the PDF instructions from MFB and can kind of follow them, but I do not even know if it matters whether the Dom 1 should be turned off or on when connecting the cable.
Thanks for any advice and promise I will try to enter the 21st century at some point!
Old 7th April 2016 | Show parent
  #1608
Gear Addict
 
SynthesizerPatel's Avatar
 
🎧 10 years
Quote:
Originally Posted by The Lurcher ➡️
Hey all really glad that the update problem has been fixed!!
Now for the embarrassing bit - as much as I have owned and used analog synths over the last 35 years I am a complete newbie in regards to sysex / midiox etc. so am concerned about doing the update. I have midiox (am on PC not Mac) and the correct interface midi leads etc. Have used it once to update the OS on my Pro 2 but DSI sent me idiot proof instructions on what to do and it went smoothly. I am not useless with computers, used them for many years but just have no experience with midiox and I just don't want to cock this up!
I'm kinda hoping that one of you out there has the patience to put an idiot proof list of how exactly to do this. Obviously I have opened the PDF instructions from MFB and can kind of follow them, but I do not even know if it matters whether the Dom 1 should be turned off or on when connecting the cable.
Thanks for any advice and promise I will try to enter the 21st century at some point!
Don't worry mate, you're not alone.

Some explicit instructions (for Windows) would be appreciated here too.
Old 7th April 2016 | Show parent
  #1609
Gear Addict
 
The Lurcher's Avatar
 
🎧 5 years
Quote:
Originally Posted by SynthesizerPatel ➡️
Don't worry mate, you're not alone.

Some explicit instructions (for Windows) would be appreciated here too.
Good to know I'm not alone in my ignorance - all my synths before getting the Pro 2 / Dom 1 were old vintage and hence have never had to use sysex / midiox until now so I need to get my head round it.
Old 7th April 2016
  #1610
Gear Addict
 
The Lurcher's Avatar
 
🎧 5 years
Idm0r you are a true gentlemen, very much appreciated. Will get this done.
Old 7th April 2016
  #1611
Here for the gear
 
🎧 5 years
I have the same problem with the ARP, just one velocity, but I also have the feeling I'm missing something. Maybe tripbeat can clarify what the key OS is really supposed to do. Or anyone else for that matter.
Old 7th April 2016
  #1612
Gear Addict
 
The Lurcher's Avatar
 
🎧 5 years
Just realised what I wrote in previous post, you might be a lady in which case you are a true lady! Either way many thanks and I will shut up before the hole I am digging gets any deeper
Old 7th April 2016 | Show parent
  #1613
Gear Addict
 
The Lurcher's Avatar
 
🎧 5 years
Quote:
Originally Posted by idm0r ➡️


No worries, I'm a duder .
That's a relief! Thoughts of transgender occurred to me then what should I have put. Still I can't talk I'm a dog.
Old 8th April 2016
  #1614
Gear Addict
 
SynthesizerPatel's Avatar
 
🎧 10 years
I can't get MIDI-OX to detect the Dominion.
Old 8th April 2016 | Show parent
  #1615
Gear Addict
 
SynthesizerPatel's Avatar
 
🎧 10 years
Quote:
Originally Posted by idm0r ➡️
Not sure what you mean by 'detect'. There's nothing to 'detect' really. It will just send the midi data to the MIDI out of your audio interface and if setup correctly, Dominion 1 will automatically switch to receive the data (it will say "updating" in the small display).

Did you check if the MIDI channel on dominion 1 is set to 1?
Have you selected the correct MIDI out port in midi OX?
By "not detected", I mean the Dominion isn't showing up in the MIDI Devices list in MIDI-OX. Dominion IS set to channel 1, as is MIDI-OX (I think).
Old 8th April 2016
  #1616
Here for the gear
 
🎧 5 years
I did a MIDIOX/Windows update and the Dominion doesn't show up in MIDIOX, nor does it have to. It's just like idm0R said: the only thing you'll see is your interface/soundcard when you set the MIDI Devices under options. I think I remember seeing an Apple screenshot here, where the Dominion1 shows up on the list. But that's only in Appleworld I supppose.
The Dom is connected via MIDI to your soundcard/interface and that should be enough.
Old 9th April 2016
  #1617
Gear Addict
 
SynthesizerPatel's Avatar
 
🎧 10 years
Ok, I did the Keyboard update but I don't think the Dominion actually received anything - nothing on it or its display any sign of anything happening.
Also I tried to run the other midi file but kept getting a popup saying nothing to output to.

So, I doubt anything's been updated. :-(
Old 9th April 2016 | Show parent
  #1618
Lives for gear
 
magikroom's Avatar
 
🎧 5 years
Quote:
Originally Posted by SynthesizerPatel ➡️
Ok, I did the Keyboard update but I don't think the Dominion actually received anything - nothing on it or its display any sign of anything happening.
Also I tried to run the other midi file but kept getting a popup saying nothing to output to.

So, I doubt anything's been updated. :-(
I ran the keyboard update first and nothing happened, then I ran the OS update and that worked, then ran the keyboard update after, which then worked. I use a mac and sysex edit. If it is updating, the 3 digit screen will scroll "Upd...."
Old 10th April 2016 | Show parent
  #1619
Gear Nut
 
Visible Cow's Avatar
 
🎧 10 years
I was able to update the OS (using midi ox) but can't seem to get the keyboard update to work. I've followed all of the directions as far as I can tell.

Edit: Scratch that, I figured it out by tweaking the midi ox settings although I have not checked the new functionality.

Last edited by Visible Cow; 11th April 2016 at 01:41 AM..
Old 12th April 2016
  #1620
Gear Nut
 
🎧 10 years
my dog enjoying the new update...
Attached Thumbnails
MFB Dominion 1-img_2894.jpg  
📝 Reply

Similar Threads

Thread / Thread Starter Replies / Views Last Post
replies: 104 views: 38513
Avatar for automating
automating 11th August 2016
replies: 530 views: 112634
Avatar for pheff1
pheff1 3 weeks ago
replies: 76 views: 6420
Avatar for jm2c
jm2c 18th November 2020
replies: 597 views: 92829
Avatar for LAN
LAN 3 days ago
Topic:
Post Reply

Welcome to the Gearspace Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…

Forum Jump
Forum Jump