Quantcast
Roland Alpha Juno-2 keyboard not working - Gearspace.com
The No.1 Website for Pro Audio
Roland Alpha Juno-2 keyboard not working
Old 21st January 2013
  #1
Lives for gear
 
AnthonyRochester's Avatar
 
🎧 10 years
Roland Alpha Juno-2 keyboard not working

I just posted this as a reply in an old thread but decided a new thread would be more helpful..

I have an alpha juno 2 and since I got it the keyboard never worked at all – I’ve only played it from another midi keyboard. Now that other keyboard is broken and I have no way to play the alpha juno 2 now, so I thought I would have another go at investigating why the keyboard doesn’t work. I’ve opened it up, examined all the internal connections, and everything looks OK. Do you guys have any ideas?
Old 21st January 2013
  #2
Gear Guru
 
1 Review written
🎧 10 years
Not a single key works?

I recently fixed mine, just opened it up.. took the rubber membrane things off... and just cleaned the paths on the board under them with a Q-tip and alcohol.

Works great now, .. but I can't get my aftertouch to work still.
Old 21st January 2013
  #3
Gear Guru
 
1 Review written
🎧 10 years
this might help

Roland Alpha Juno 2 Synthesizer Repairs
Old 21st January 2013
  #4
Lives for gear
 
AnthonyRochester's Avatar
 
🎧 10 years
Not a single key works, so I don't think its an issue of dirty contacts on the keys (I had a look at the contacts and they look nice and clean).
You know the connector for the aftertouch is the small flat cable coming off the left end of the keyboard, right?
Old 21st January 2013
  #5
Lives for gear
 
AnthonyRochester's Avatar
 
🎧 10 years
djugel - yeah I did see that article already. His just had a few dead keys that he fixed, but with mine, the whole keyboard doesn't work, so I'm sure its a different problem.
Old 21st January 2013
  #6
Gear Addict
 
🎧 5 years
Is there a local control on/off on the alpha? If so make sure that local control is on.
Old 21st January 2013 | Show parent
  #7
Lives for gear
 
AnthonyRochester's Avatar
 
🎧 10 years
Quote:
Originally Posted by itege ➡️
Is there a local control on/off on the alpha? If so make sure that local control is on.
Good idea - I just checked and its not a physical switch but a parameter you can change, and it is on. I can see on my interface (digi003) that the joystick is sending midi information but they keyboard isn't.
Old 21st January 2013
  #8
Gear Guru
 
1 Review written
🎧 10 years
Yes, I've tried the ribbon thing.. still no luck.
not a big deal because I don't use mine as a MIDI controller.

Yeah, I was going crazy until I figured out you have to SAVE your system settings.
📝 Reply

Similar Threads

Thread / Thread Starter Replies / Views Last Post
replies: 1417 views: 194876
Avatar for xanderbeanz
xanderbeanz 4 days ago
replies: 2140 views: 206224
Avatar for Don Solaris
Don Solaris 23rd August 2012
replies: 160 views: 23729
Avatar for Jamie munro
Jamie munro 12th December 2019
Topic:
Post Reply

Welcome to the Gearspace Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…

Forum Jump
Forum Jump