Quantcast
Can't get Omnisphere to receive MIDI in Logic - Gearspace.com
The No.1 Website for Pro Audio
Can't get Omnisphere to receive MIDI in Logic
Old 25th November 2009
  #1
Gear Head
 
๐ŸŽง 10 years
Can't get Omnisphere to receive MIDI in Logic

Hi,

I've tried looking around for an answer to this, but can't find anything. I'm receiving MIDI from an external Roland RD600 keyboard via midi cables into my MOTU Traveler and am definitely receiving note information as I can play things like VSL and EXS24 instruments fine. The different notes appear on the transport bar when I play as well.

However, Omnisphere won't play anything unless I use the Caps-lock keyboard in Logic or draw the notes in. Can't find anywhere to change these settings either - tried setting up my keyboard in Audio-MIDI Setup, but nada.

Any ideas what I can try next?

Thanks

PS, I'm using: Snow Leopard on a MBP 2GHz with 2gig ram
Old 25th November 2009
  #2
Gear Maniac
 
idiotboy's Avatar
 
๐ŸŽง 10 years
I don't use Omnisphere, but it may be set to receive MIDI on a different MIDI channel than the one your keyboard is transmitting on.

Look in the Omnisphere documentation for how to set the MIDI receive channel.
Old 25th November 2009 | Show parent
  #3
Lives for gear
 
Dr.Wu's Avatar
 
๐ŸŽง 15 years
by default the 8 parts in Omnisphere respond to channels 1-8.
If the instrument in Logic is set to ALL whatever MIDIchannel your keyboard transmits on is being passed on to the plug in.
Maybe your keyboard is sending on channels 9-16.
Try changing the ALL setting in the Logic instrumet info to 1-8.
That will rechannelize your keyboardinput.
Load a sound into the appropiate part in Omni and you should be able to play that.
Old 26th November 2009 | Show parent
  #4
Gear Head
 
๐ŸŽง 10 years
Sometimes the answer is so simple.... thanks for your help, I genuinely thought 'all' would include channels 1-8 as it works with all other instruments.
Old 26th November 2009 | Show parent
  #5
Lives for gear
 
Dr.Wu's Avatar
 
๐ŸŽง 15 years
Glad it works for you now.
If your other instruments respond to the ALL setting i think they might be set to OMNI-mode so they receive on any channel that is send from your keyboard into Logic.
๐Ÿ“ Reply

Similar Threads

Thread / Thread Starter Replies / Views Last Post
replies: 53 views: 3535
Avatar for Plush
Plush 23rd April 2006
replies: 2380 views: 409329
Avatar for didier.brest
didier.brest 3 weeks ago
replies: 504 views: 61708
Avatar for rids
rids 2nd November 2020
replies: 52 views: 6886
Avatar for pluto_ro
pluto_ro 4 weeks ago
Post Reply

Welcome to the Gearspace Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…

Forum Jump
Forum Jump