Quantcast
JX8P sending incomplete data as sysex? - Gearspace.com
The No.1 Website for Pro Audio
JX8P sending incomplete data as sysex?
Old 18th January 2019
  #1
JX8P sending incomplete data as sysex?

So here's a problem I have been having: it seems like my JX is not sending the complete patch or is just sending parts of it - it can't read or acknowledge the patch I've saved on Sysex Librarian. Occasionally it will get some part of it, as it will advance to another patch, but won't update that patch slot. Or maybe it's just sending random CC #s ? I've slowed down the transmission speed (I remember these sorts of problems with my Poly-800 so many years ago) but that hasn't helped. I can load other patches from SL onto it but not the patches I dump back from the JX8P. So I think something is getting corrupted along the way.

Or I am not actually sending the patch like I want to? There does not seem to be technical procedure listed out in there on the internets but I've got the JX on channel 1, sysex enabled, enable recorded in SL, and then push the patch # of the patch I want to record, which then SL records as around a 10kb file.

Using a Roland UM One if it makes any difference.

Also: the JX8P won't send from the patch you are currently on, only when pressing and moving to a different patch will it send data. Is this normal behavior? I.e. if already on patch 17, pushing it again does not send data, but any other button will send when pushed.
Old 18th January 2019
  #2
Deleted 859c1b8
Guest
I have both loaded and saved from the Roland UM-1 to my computer all my patches via MIDI-OX.
No problems here.
Remember this synth is 1985, not 2017, so you have to bend to the technology of the day.
Old 18th January 2019
  #3
Deleted 859c1b8
Guest
So you load up your midiox, roland um-1.
You set up Receive Bulk dump.
Press 1, 2, 3.....etc until you are done.
Save,
now you have all patches as sysex.
Old 18th January 2019 | Show parent
  #4
Quote:
Originally Posted by Zaphod Betamax ➡️
So you load up your midiox, roland um-1.
You set up Receive Bulk dump.
Press 1, 2, 3.....etc until you are done.
Save,
now you have all patches as sysex.
Yes - however the patches cannot be reloaded and read by the JX. That's why I think something is being corrupted. So the procedure seems to be correct but something is happening down the line...
Old 18th January 2019 | Show parent
  #5
Deleted 859c1b8
Guest
Not the results I got.
YMMV, and it looks like it does.


Quote:
Originally Posted by yvesmalone ➡️
Yes - however the patches cannot be reloaded and read by the JX. That's why I think something is being corrupted. So the procedure seems to be correct but something is happening down the line...
Old 18th January 2019
  #6
Deleted 859c1b8
Guest
Also the settings of the buffers in midiox are important.
Alas, I did all this back in 2015, so I no longer know the setttings.
Old 18th January 2019
  #7
Deleted 859c1b8
Guest
Try this as a start...
#9


MIDIOX
Old 18th January 2019 | Show parent
  #8
Quote:
Originally Posted by Zaphod Betamax ➡️
Try this as a start...
#9


MIDIOX
Unfortunately I am a Mac guy, so MidiOX is out.

It looks like most patches are 89 bytes so I am definitely not getting all the patch sent, I think all that's really sending is the patch location.

HOWEVER
I think I've figured it out, at least for my synth:

You have to hit the patch key twice (record multiple): first message seems to be location, second message the data. That's not in any manual I've read nor very intuitive. And once again, you can't do it from the patch location you are currently on. WTF?

Maybe this could be due to my OS 3.0 (hold P1 while turning on), as the final OS was 3.1

Well, at least I've hurdled that nonsense, thanks for hanging in there with me...
Old 19th January 2019
  #9
Deleted 859c1b8
Guest
Tried it!
One button press 32 times into midox saved it.
As a Russian Roluette I loaded this sysex back to the 8P and it was fine.
No double press required with UM-1>Win 7>MidiOx.

My 8P is actually for sale as I put it on kijiji.
Old 19th January 2019
  #10
Deleted 859c1b8
Guest
Mine is 3.1...back to storage it goes.
Old 19th January 2019 | Show parent
  #11
Quote:
Originally Posted by Zaphod Betamax ➡️
Tried it!
One button press 32 times into midox saved it.
As a Russian Roluette I loaded this sysex back to the 8P and it was fine.
No double press required with UM-1>Win 7>MidiOx.

My 8P is actually for sale as I put it on kijiji.
I think I finally sussed it out: it may have been due to crud/corrosion in the memory protect switch -after exercising that out a bit all of a sudden it would send two messages with one press. Who woulda thought that would work?
Certainly not me, but I've been dumping my patches and reloading them with no troubles today.
📝 Reply
Topic:
Post Reply

Welcome to the Gearspace Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…

Forum Jump
Forum Jump