Quantcast
Help with setting up my MIDI studio. Logic X, Mackie MCU, Arturia Spark, etc... - Gearspace.com
The No.1 Website for Pro Audio
Help with setting up my MIDI studio. Logic X, Mackie MCU, Arturia Spark, etc...
Old 12th March 2014
  #1
Here for the gear
 
🎧 5 years
Help with setting up my MIDI studio. Logic X, Mackie MCU, Arturia Spark, etc...

I use the Mackie MCU Pro system (MCU, XT & C4) as a control surface for Logic X on OS X 10.9.

The MCU is connected via USB to my Mac. The XT & C4 extensions are both connected to the MCU's MIDI I/O via MIDI cables.

I also have Arturia Spark CDM 1.7.1 and a Roland A-49 keyboard both also connected via USB to my Mac.

I have Spark setup exactly as described in Arturia's document on Logic X setup.

My issue is, when I open a Logic X project containing Spark as a plugin, the MCU control surface seems to work perfectly fine until I select the track containg Spark and the Spark hardware controller "connects" to the plugin. After that, I get a big delay receiving feedback data on the MCU from Logic. As in, LEDs lighting etc. Further, I sometimes encounter delays with Spark. Like when hitting the pads, a latency with the sound. Plus sometimes Spark triggers things on my MCU.

Also, once Spark has connected to the hardware. If I select a different track in Logic, MIDI arm a different instrument, when I use Spark hardware, it triggers Spark plugin and the instrument on the selected track. I'd like to have the data not overlap with the devices.

If possible...

- I'd like to have my MCU control surfaces always control Logic X with no overlapping data from other devices if possible.

- I'd like my Roland A-49 to control any MIDI armed track in my session (including Spark when that track is MIDI armed, if necessary)

- I'd like Spark CDM to only control the Spark plugin with no data controlling any other instruments and also control Spark plugin even if a different instrument is MIDI armed.

Can someone more experienced with MIDI configuring tell me how I should optimize my communication in my MIDI studio. Using either the Audio/MIDI Utility or Logic X settings?

I also posted in Arturia's forum... Any help is much appreciated!
Old 12th March 2014
  #2
Here for the gear
 
🎧 5 years
Although the Arturia document says to enable "Send MIDI from sequencer" & "Send MIDI from Pads" within Spark. I found that disabling both fixed all my problems I stated above.
📝 Reply

Similar Threads

Thread / Thread Starter Replies / Views Last Post
replies: 81 views: 28139
Avatar for asoul4asoul
asoul4asoul 31st July 2009
replies: 79 views: 32993
Avatar for rids
rids 1st July 2009
replies: 169 views: 52600
Avatar for Scoox
Scoox 17th October 2020
replies: 965 views: 258391
Avatar for CustomStudios
CustomStudios 29th March 2021
Post Reply

Welcome to the Gearspace Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…

Forum Jump
Forum Jump