The No.1 Website for Pro Audio
Can't Download Logic Pro X for Mojave
Old 13th January 2021
  #1
Gear Head
 
Daniel Rimedio's Avatar
 
🎧 5 years
Can't Download Logic Pro X for Mojave

hello, I really have a big problem and I can not find a solution. My iMac Late 2013 has broken. So I bought a used Mac mini 2018 with Mac OS Mojave. I am still forced to work with Mojave at the moment because my interface Metric Halo ULN 8 does not support Catalina until I upgrade my hardware. So I thought I'm smart and buy the Mac mini 2018 to keep my Metric Halo running.

So far so good.

I have now set up the Mac mini so far and now wanted to download Logic Pro X.
But I'm not allowed to do that because it seems that it is now only downloadable from Mac OS 10.15.7.

Does anyone have an idea how I can download and install Logic for Mojave? After all, I paid for the software.

Is there a workaround to get older Logic installers for Mac OS Mojave?

Thanks a lot!

Translated with www.DeepL.com/Translator (free version)
Old 14th January 2021
  #2
Gear Nut
 
Go to the “Purchases” in your App Store.
You should be able to download the last compatible version of Logic Pro available for your Mojave OS.
Old 9th February 2021
  #3
Here for the gear
 
Not that I know. I run into the same problem, and had to update to Catalina. Any previous versions of Logic are not available anywhere on the App Store, at least since they released 15.6.
Old 1st March 2021
  #4
Lives for gear
 
Just ran into this issue. Just updated my iMac and Macbook Air from Sierra to High Sierra (most recent OS my old 2011 iMac will support) and wanted to sync versions of Logic Pro X on both. The iMac already has Logic 10.4.4 and the Macbook Air only has 10.2.4.

Read that I could go to the app store and it would download the most recent compatible version. Nope - the pop up to download the most recent compatible version just keeps popping up, and no download ever happens.

Looks like I'm stuck with 2 different versions of Logic (not the end of the world) until I upgrade my iMac. Bummer.
Old 2nd March 2021 | Show parent
  #5
Gear Maniac
 
🎧 15 years
Quote:
Originally Posted by sirjuxtable ➡️
Just ran into this issue. Just updated my iMac and Macbook Air from Sierra to High Sierra (most recent OS my old 2011 iMac will support) and wanted to sync versions of Logic Pro X on both. The iMac already has Logic 10.4.4 and the Macbook Air only has 10.2.4.

Read that I could go to the app store and it would download the most recent compatible version. Nope - the pop up to download the most recent compatible version just keeps popping up, and no download ever happens.

Looks like I'm stuck with 2 different versions of Logic (not the end of the world) until I upgrade my iMac. Bummer.
If you already have 10.4.4 on one Mac, you can just copy it over to your second Mac.
Old 2nd March 2021 | Show parent
  #6
Lives for gear
 
Quote:
Originally Posted by wolfger ➡️
If you already have 10.4.4 on one Mac, you can just copy it over to your second Mac.
You know, that's not a bad idea. Is the app file all I need to port over?
Old 2nd March 2021 | Show parent
  #7
Gear Maniac
 
🎧 15 years
Quote:
Originally Posted by sirjuxtable ➡️
You know, that's not a bad idea. Is the app file all I need to port over?
Yes, I do this all the time with my two machines
Old 2nd March 2021 | Show parent
  #8
Lives for gear
 
Quote:
Originally Posted by wolfger ➡️
Yes, I do this all the time with my two machines
Amazing. Thank you!
Old 3rd March 2021
  #9
Gear Addict
 
🎧 10 years
You can even make an Archive of it in your applications folder then copy that over to the new Mac. That will gather up all you need. Put the version number at the end of the name and it will let you keep copies of the various versions for whenever you need them, since you can’t get them from Apple anymore.

Last edited by macmuse; 3rd March 2021 at 05:01 AM..
Old 3rd March 2021 | Show parent
  #10
Lives for gear
 
Quote:
Originally Posted by macmuse ➡️
You can even make an Archive of it in your applications folder then copy that over to the new Mac. That will gather up all you need. Put the version number at the end of the band and it will let you keep copies of the various versions for whenever you need them, since you can’t get them from Apple anymore.
Yep, this occurred to me as well since I don't want to be in this position again if I ever need to go backwards for whatever reason. Saving the older version is probably wise. Thanks!
Old 3rd March 2021
  #11
Gear Addict
 
🎧 10 years
And by archive I mean select Logic in the app folder and right click to archive/zip it, just to be clear.

I’ve done that and then store them all in a folder somewhere, just in case I need them.
Old 3rd March 2021 | Show parent
  #12
Lives for gear
 
Quote:
Originally Posted by macmuse ➡️
And by archive I mean select Logic in the app folder and right click to archive/zip it, just to be clear.

I’ve done that and then store them all in a folder somewhere, just in case I need them.
Thank you. That's not a function I've used before so I appreciate you being explicit.
Old 4th March 2021 | Show parent
  #13
Gear Addict
 
🎧 10 years
Quote:
Originally Posted by sirjuxtable ➡️
Thank you. That's not a function I've used before so I appreciate you being explicit.
Actually the word Apple uses in the contextual (right-click) menu is ‘Compress’, not ‘archive’. Sorry!
📝 Reply

Similar Threads

Thread / Thread Starter Replies / Views Last Post
replies: 3321 views: 867726
Avatar for Tronam
Tronam 30th January 2021
replies: 1188 views: 190576
Avatar for jonljacobi
jonljacobi 15th June 2019
Post Reply

Welcome to the Gearspace Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…

Forum Jump
Forum Jump