Quantcast
Logic Pro: Hearing audio I'm punching in over while recording. Help please! - Gearspace.com
The No.1 Website for Pro Audio
Logic Pro: Hearing audio I'm punching in over while recording. Help please!
Old 29th July 2017
  #1
Gear Nut
 
🎧 15 years
Logic Pro: Hearing audio I'm punching in over while recording. Help please!

This is weird one that just started for me. When I'm recording over a track or punching in over a track, I hear the material I'm recording over (instead of the way it should "normally" function where it mutes/records over the existing material on the track). So for instance, if I punch in a guitar track, I still hear the previous take as well as the new take. The only way for me to deal with it is to mute the track I'm recording onto (so that I don't hear the previous material).

If I turn ON audio input monitoring, the problem goes away. As I'm recording through a UA Apollo 8, I do not want to use Logic's audio input monitoring because it creates a double monitoring situation with latency (I monitor via the Apollo) and I can't figure out how to fix this. Seems like a few other people had a similar problem over the years when I search the web, but no solution was found.

Any help to alleviate me from this annoyance would be much appreciated.

I'm running Logic Pro X 10.3.1. Thanks kindly in advance for any advice!
Old 30th July 2017
  #2
Lives for gear
 
Jay Asher's Avatar
 
🎧 5 years
Did you set your recording prefs to Replace or turn on the Replace button in the Control Bar??
Old 30th July 2017
  #3
Lives for gear
 
🎧 5 years
You need to turn off Software Monitoring also if you monitor through the Apollo. But I guess it's already off. It's of course a personnal thing if you prefer to do punching in/out, but with the Take comping features, I now record over the darn track when I want to redo something over and "comp it" afterwards. But to each his/her own.

KA
Old 31st July 2017
  #4
Gear Nut
 
🎧 15 years
It's strange. I have cycled through all the various record modes (Replace / Create new track / Create track alternative, etc) and they all behave the same. I have software monitoring (Audio Input Monitoring) turned off in Logic. But when I record over a track, I'm still hearing the material that I'm recording over while I'm recording the new audio. Once I'm finished recording, I of course hear the new audio and/or it's there for me to comp if it's a track alternative or in the take folder. But it is annoying that I'm hearing the audio that I'm replacing. Been working in Logic for a long time and never had this problem. Maybe a setting got out of whack during the last update?
Old 1st August 2017
  #5
Gear Nut
 
🎧 15 years
After a long process of elimination I've figured out that this problem is only happening when "Enable Quick Punch" is engaged. If I turn that off, everything works as suspected. I imagine this is a bug in the software? But now as Logic functions the same regardless of if "Enable Quick Punch" is engaged, I'm beginning to wonder if I understand what that selection does in the first place : /.
Old 1st August 2017 | Show parent
  #6
Lives for gear
 
Jay Asher's Avatar
 
🎧 5 years
Quote:
Originally Posted by tasker ➑️
After a long process of elimination I've figured out that this problem is only happening when "Enable Quick Punch" is engaged. If I turn that off, everything works as suspected. I imagine this is a bug in the software? But now as Logic functions the same regardless of if "Enable Quick Punch" is engaged, I'm beginning to wonder if I understand what that selection does in the first place : /.
Quick punch allows you to punch in and punch out while the project keeps playing, tape recorder style. When combined with Replace, it should be the behavior you seem to be wanting.
Old 1st August 2017 | Show parent
  #7
Gear Nut
 
🎧 15 years
Quote:
Originally Posted by Jay Asher ➑️
Quick punch allows you to punch in and punch out while the project keeps playing, tape recorder style. When combined with Replace, it should be the behavior you seem to be wanting.
That's exactly what I'm looking for. Oddly, that's the way Logic has always behaved for me, but something got out of whack and it stopped behaving like that.

Even odder, it's currently only working in the way you describe (which is the way I'd like it to work) when Quick Punch is deactivated. Weird. Maybe I'll try trashing the prefs.
Old 1st August 2017 | Show parent
  #8
Lives for gear
 
Jay Asher's Avatar
 
🎧 5 years
Quote:
Originally Posted by tasker ➑️
That's exactly what I'm looking for. Oddly, that's the way Logic has always behaved for me, but something got out of whack and it stopped behaving like that.

Even odder, it's currently only working in the way you describe (which is the way I'd like it to work) when Quick Punch is deactivated. Weird. Maybe I'll try trashing the prefs.

Are you using the key command for Record/Record toggle or setting record to it?

It works perfectly here. You will of course here the already recorded audio when you are not punching in.
Attached Thumbnails
Logic Pro: Hearing audio I'm punching in over while recording. Help please!-screen-shot-2017-08-01-1.22.45-pm.jpg  
Old 1st August 2017 | Show parent
  #9
Gear Nut
 
🎧 15 years
Quote:
Originally Posted by Jay Asher ➑️
Are you using the key command for Record/Record toggle or setting record to it?

It works perfectly here. You will of course here the already recorded audio when you are not punching in.
Yea, I'm set up exactly like you are. Trashed the prefs to no avail. It's still giving me the same problem. When I turn quick punch off, it works ok but it doesn't come in and out with the quickness that it should. I'm using "*" to punch in and out and am continuing to hear the audio that I'm attempting to record over.

For example, in the image I'm uploading, I'm hearing the "blue" audio while I'm recording on top of it with the red.
Attached Thumbnails
Logic Pro: Hearing audio I'm punching in over while recording. Help please!-screen-shot-2017-08-01-3.28.51-pm.jpg  
Old 1st August 2017
  #10
Lives for gear
 
Jay Asher's Avatar
 
🎧 5 years
Hmm, maybe the drive you are recording to is not a happy camper.
Old 1st August 2017
  #11
Gear Nut
 
🎧 15 years
I've tried about everything in the book. But I'll give that one a go. It's an internal SSD with plenty of room but you never know. Strange thing is this is the only problem I'm having with it. It's fine mixing a 48 track session with lots of plug ins. In any case, thanks for your help. The mystery continues...
Old 1st August 2017
  #12
Lives for gear
 
Jay Asher's Avatar
 
🎧 5 years
Good luck.
Old 1st August 2017
  #13
Gear Nut
 
🎧 15 years
Thanks. I'm thinking it must be a setting somewhere that's causing this to happen. Just haven't been able to find it yet!
Old 1st August 2017
  #14
Gear Nut
 
🎧 15 years
Posting the solution up here in case anyone else has this problem. I trashed everything, even reinstalled Logic and nothing worked until I found this fix on a different board. Seems that Logic updated this setting in my Preferences during an update. In any case, here's the solution (FYI - The setting in Logic 10.3.2 is under Preferences > Audio > General):

i have your answer. it ended up (at least on my friends system that ran across this issue) being in your preferences under the preferences > general> make sure software monitoring is UNchecked.
Old 4th March 2019 | Show parent
  #15
Here for the gear
 
This worked perfectly!! Thanks
Old 4th March 2019
  #16
Gear Guru
 
jwh1192's Avatar
 
2 Reviews written
🎧 15 years
i swear in older versions of Logic it was Called "Tape Machine Style" or am i crazy and it was another DAW ??
Old 5th March 2019 | Show parent
  #17
Lives for gear
 
Jay Asher's Avatar
 
🎧 5 years
Quote:
Originally Posted by jwh1192 ➑️
i swear in older versions of Logic it was Called "Tape Machine Style" or am i crazy and it was another DAW ??

I won't speculate on your state of mind, but no, it was never called that in Logic, although I did so in my "Going Pro With Logic Pro" books.
Old 5th March 2019 | Show parent
  #18
Gear Guru
 
jwh1192's Avatar
 
2 Reviews written
🎧 15 years
Quote:
Originally Posted by Jay Asher ➑️
I won't speculate on your state of mind, but no, it was never called that in Logic, although I did so in my "Going Pro With Logic Pro" books.
thx Jay, maybe thats where i saw it ... i had that book !!! who knows where it is now .. ha ..

or it was Cubase !!
Old 27th August 2019
  #19
Here for the gear
 
None of the above suggestions works for me until I extended the goldish yellow cycle area to the left of the red recording area on the marker bars. That worked.

Last edited by Mixytocin; 27th August 2019 at 12:35 AM.. Reason: Spelling
Old 28th August 2019
  #20
Gear Nut
 
🎧 10 years
Quote:
Originally Posted by tasker ➑️
This is weird one that just started for me. When I'm recording over a track or punching in over a track, I hear the material I'm recording over (instead of the way it should "normally" function where it mutes/records over the existing material on the track). So for instance, if I punch in a guitar track, I still hear the previous take as well as the new take. The only way for me to deal with it is to mute the track I'm recording onto (so that I don't hear the previous material).

If I turn ON audio input monitoring, the problem goes away. As I'm recording through a UA Apollo 8, I do not want to use Logic's audio input monitoring because it creates a double monitoring situation with latency (I monitor via the Apollo) and I can't figure out how to fix this. Seems like a few other people had a similar problem over the years when I search the web, but no solution was found.

Any help to alleviate me from this annoyance would be much appreciated.

I'm running Logic Pro X 10.3.1. Thanks kindly in advance for any advice!
I have the same problem and posted about it a few weeks ago. Weird. I have no idea what's causing it.
Old 18th March 2020
  #21
Here for the gear
 
🎧 5 years
turn off Software monitoring in preferences > Audio > General. It's some sort of bug.

James
Bad Racket Recording
Old 4th July 2020
  #22
Here for the gear
 
A FIX!!!

Managed to fix this on my system and hoping this may help someone else avoid the months of head scratching it's caused me.

....I had a Logic Track template setup for vocals with Melodyne (ARA) in the first FX slot; and after a process of elimination; removing Melodyne or just disabling it while you record vocals will stop this problem of hearing old takes!

Hope that helps people (could be caused by other 3rd party plugins too I'd guess)
Old 26th November 2020
  #23
Here for the gear
 
🎧 5 years
Yes just found this by trying different ways to record.
1. Enable Quick Punch
2. Highlight (choose the track you want to record on in the arrange window).
3. DO NOT enable the record button. (If you enable the record button you will hear your previous take.) REALLLY WEIRD BEHAVIOR.
Why would anyone want that APPLE?
4. When you get to your punch in point hit R to punch in and R again to punch out.

Check it out
SAL
Angel Studio
Old 26th November 2020
  #24
Here for the gear
 
🎧 5 years
Yes just found this by trying different ways to record.
1. Enable Quick Punch
2. Highlight (choose the track you want to record on in the arrange window).
3. DO NOT enable the record button. (If you enable the record button you will hear your previous take.) REALLLY WEIRD BEHAVIOR.
Why would anyone want that APPLE?
4. When you get to your punch in point hit R to punch in and R again to punch out.

Check it out
SAL
Angel Studio
πŸ“ Reply

Similar Threads

Thread / Thread Starter Replies / Views Last Post
replies: 3321 views: 875787
Avatar for Tronam
Tronam 30th January 2021
replies: 2405 views: 420258
Avatar for pkane
pkane 1 hour ago
replies: 58 views: 9039
Avatar for Marsdy
Marsdy 17th February 2014
Topic:
Post Reply

Welcome to the Gearspace Pro Audio Community!

Registration benefits include:
  • The ability to reply to and create new discussions
  • Access to members-only giveaways & competitions
  • Interact with VIP industry experts in our guest Q&As
  • Access to members-only sub forum discussions
  • Access to members-only Chat Room
  • Get INSTANT ACCESS to the world's best private pro audio Classifieds for only USD $20/year
  • Promote your eBay auctions and Reverb.com listings for free
  • Remove this message!
You need an account to post a reply. Create a username and password below and an account will be created and your post entered.


 
 
Slide to join now Processing…

Forum Jump
Forum Jump